XOR and Favorite Number

Description

Bob has a favorite number k and ai of length n. Now he asks you to answer m queries. Each query is given by a pair li and ri and asks you to count the number of pairs of integers i and j, such that l ≤ i ≤ j ≤ r and the xor of the numbers ai, ai + 1, ..., aj is equal to k.

Input

The first line of the input contains integers n, m and k (1 ≤ n, m ≤ 100 000, 0 ≤ k ≤ 1 000 000) — the length of the array, the number of queries and Bob's favorite number respectively.

The second line contains n integers ai (0 ≤ ai ≤ 1 000 000) — Bob's array.

Then m lines follow. The i-th line contains integers li and ri (1 ≤ li ≤ ri ≤ n) — the parameters of the i-th query.

Output

Print m lines, answer the queries in the order they appear in the input.

Sample Input

Input
6 2 3
1 2 1 1 0 3
1 6
3 5
Output
7
0
Input
5 3 1
1 1 1 1 1
1 5
2 4
1 3
Output
9
4
4

Sample Output

21 0
85 5
789 62

Hint

In the first sample the suitable pairs of i and j for the first query are: (1, 2), (1, 4), (1, 5), (2, 3), (3, 6), (5, 6), (6, 6). Not a single of these pairs is suitable for the second query.

In the second sample xor equals 1 for all subarrays of an odd length.


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <math.h>
#include <set>
#include <iomanip>
using namespace std;
#define eqs 1e-9
#define INF 0x3f3f3f3f
#define MOD 100000000
#define MAXN 100010

long long n,m,k,nn;
long long ori[MAXN];
long long num[1<<20];
long long cnt[MAXN];
long long ans;

struct node
{
    int l,r,id;
    bool operator < (const node b)const
    {
        return (l/nn!=b.l/nn)?l/nn<b.l/nn:r<b.r;
    }
}p[MAXN];

void add(long long x)
{
    ans += num[x^k];
    num[x]++;
}
void del(long long x)
{
    num[x]--;
    ans -= num[x^k];
}

int main()
{
    while( ~scanf("%lld%lld%lld",&n,&m,&k) )
    {
        memset(num,0,sizeof(num));
        nn = ceil(sqrt(n*1.0));
        ori[0] = 0;
        for( int i = 1; i <= n; i++ )
        {
            scanf("%lld",&ori[i]);
            ori[i] = ori[i-1]^ori[i];
        }
        for( int i = 0; i < m; i++ )
        {
            scanf("%d%d",&p[i].l,&p[i].r);
            p[i].l--;
            p[i].id = i;
        }
        sort(p,p+m);
        int l = 3,r = 2;
        ans = 0;
        for( int i = 0; i < m; i++ )
        {
            //cout<<l<<" "<<r<<endl;
            //cout<<p[i].l<<" "<<p[i].r<<endl;
            //cout<<ans<<endl;
            while( p[i].r > r )
            {
                    add(ori[++r]);
                    //cout<<ori[r]<<" 11 "<<ans<<endl;
            }
            while( p[i].r < r )
            {
                    del(ori[r--]);
                   // cout<<ori[r+1]<<" 22 "<<ans<<endl;
            }
            while( p[i].l > l )
            {
                    del(ori[l++]);
                    //cout<<ori[l-1]<<" 33 "<<ans<<endl;
            }
            while( p[i].l < l )
            {
                    add(ori[--l]);
                    //cout<<ori[l]<<" 44 "<<ans<<endl;
            }
            cnt[p[i].id] = ans;
            //for( int i = 0; i <= 6; i++ )
                //cout<<num[i]<<" ";
            //cout<<endl;
        }
        for( int i = 0; i < m; i++ )
            printf("%I64d\n",cnt[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值