POJ 1035 Spell checker

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

Northeastern Europe 1998

/*
    刚开始想用字典树,方便查找来节约时间,等字典树敲完之后发觉这个题用字典树来操作似乎麻烦的很。题目大意就是先给你一些词,让你组成一个词典,然后以#号结束,之后再给你一些字符,问你是否可以通过增加、删除或改变词典中某个词的一个字符让两个字符相等,当然,如果词典里已经有这个词的时候就输出correct。
   
     方法是像是字符串哈希,把所有的词先存起来,然后给予查询的字符串去词典中找,有相同的就输出correct否则就依次寻找有没有和目标词汇字符长度差1的词,找到之后判断能否操作就好了。注意有坑,当时用if去查fi的时候也是输出可以替换,其实要经过两步才可以。
*/


#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
const int INF = 0x3f3f3f3f;
using namespace std;

char a[10010][20],b[10010][20];
char str[20];

int main()
{
    int top = 0,kep = 0;
    while(scanf("%s",&a[top]) && strcmp(a[top],"#"))
        top++;
    while(scanf("%s",str) && strcmp(str,"#"))
    {
        kep = 0;
        bool flag = true;
        for(int i=0; i<top; i++)
        {
            if(!strcmp(a[i],str))
            {
                printf("%s is correct\n",str);
                flag = false;
                break;
            }
            else
            {
                int len1 = strlen(str);
                int len2 = strlen(a[i]);
                int s = 0;
                if(len1 == len2)
                {
                    int ant = 0;
                    for(int j=0; str[j]!='\0'; j++)
                    {
                        if(a[i][j] == str[j])
                            ant++;
                    }
                    if(ant == len2-1)
                        strcpy(b[kep++],a[i]);
                }
                else if(len1+1 == len2)//len1 str
                {
                    int ant = 0;
                    for(int j=0; a[i][j]!='\0'; j++)
                    {
                        if(a[i][j] == str[s])
                        {
                            ant++;
                            s++;
                        }
                    }
                    if(ant == len1)
                        strcpy(b[kep++],a[i]);
                }
                else if(len1 == len2+1)//len1 str
                {
                    int ant = 0;
                    for(int j=0; str[j]!='\0'; j++)
                    {
                        if(a[i][s] == str[j])
                        {
                            ant++;
                            s++;
                        }
                    }
                    if(ant == len2)
                        strcpy(b[kep++],a[i]);
                }
            }
        }
        if(flag)
        {
            printf("%s:",str);
            for(int i=0; i<kep; i++)
                printf(" %s",b[i]);
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值