关闭

Cocoapods-Unable to satisfy the following requirements

1793人阅读 评论(0) 收藏 举报
分类:

记录一个问题,之前遇到过,又忘了:

Cocoapods 更新出现如下错误

Resolving dependencies of `Podfile`
[!] Unable to satisfy the following requirements:
- `OCMock (= 3.2.1)` required by `Podfile`

提示:不能满足以下要求,并且指出了哪一行出了问题
这种情况一般是 OCMock (= 3.2.1) 中的版本号不符合要求了。

打开终端,使用命令

pod search OCMock

显示如下:

bruce-2:Example bruce$ pod search OCMock


-> Expecta+OCMock (2.1.0)
   Expecta matchers for OCMock 3.0.
   pod 'Expecta+OCMock', '~> 2.1.0'
   - Homepage: https://github.com/dblock/ocmock-expecta
   - Source:   https://github.com/dblock/ocmock-expecta.git
   - Versions: 2.1.0, 2.0.0, 1.1.0, 1.0.0 [master repo]


-> OCMock (3.1.5)
   Mock objects for Objective-C
   pod 'OCMock', '~> 3.1.5'
   - Homepage: http://ocmock.org
   - Source:   https://github.com/erikdoe/ocmock.git
   - Versions: 3.1.5, 3.1.4, 3.1.3, 3.1.2, 3.1.1, 3.1, 3.0.2, 3.0.1, 3.0, 2.2.4,
   2.2.3, 2.2.2, 2.2.1, 2.2, 2.1.1, 2.0.1, 1.77.1 [master repo]


-> OCMockito (1.4.0)
   OCMockito is an Objective-C implementation of Mockito, supporting creation,
   verification and stubbing of mock objects.
   pod 'OCMockito', '~> 1.4.0'
   - Homepage: https://github.com/jonreid/OCMockito
   - Source:   https://github.com/jonreid/OCMockito.git
   - Versions: 1.4.0, 1.3.1, 1.3.0, 1.2.0, 1.1.0, 1.0.0, 0.23, 0.22 [master
   repo]

这时候发现已经没有3.2.1了,而是3.1.5了,替换之后就可以了。
然后在使用命令pod update,如果卡住了

//如果卡在Analyzing dependencies可以尝试下面的命令
//或者
pod install --verbose --no-repo-update 
//或者
pod update --verbose --no-repo-update 

Options:
    --verbose    Show more debugging information
    --no-repo-update    不要去处理cocoapods的升级,
0
0
查看评论

Unable to satisfy the following requirements解决方案

cocoapods报错,解决方案。。。。。 [!] Unable to satisfy the following requirements: - `MJExtension` required by `Podfile` - `MJExtension (= 2.4.4)` required by ...
  • zuoyou1314
  • zuoyou1314
  • 2015-07-30 13:25
  • 20329

Unable to satisfy the following requirements解决方案

用pod update更新,结果出现下面错误 $pod update Update all pods Analyzing dependencies [!] Unable to satisfy the following requirements: - `JSQMessagesViewContro...
  • u013318565
  • u013318565
  • 2016-06-21 18:50
  • 2616

[!] Unable to satisfy the following requirements:众里寻他千百度。

今天运行pod update时报以下错误 度娘上找了很多,基本上的解决方案都是如下: $rm -fr ~/.cocoapods/repos/master  $pod setup 但是这根本不是我遇到的问题的解决方案,我的解决方案应该是将Podfile里面...
  • wolveluo
  • wolveluo
  • 2015-09-18 11:32
  • 1011

CocoaPod: 出现 Unable to satisfy the following requirements:required by 'Podfile'

Q:通过 pod 更新iOS 第三方库时报错,错误如下: 1 2 3 4 5 6 7 8 $ pod update --verbose --no-repo-update ...... Resolving dependencies of `Podfile` [!] U...
  • ouyangtianhan
  • ouyangtianhan
  • 2016-08-25 09:42
  • 784

CocoaPods 的又一个小坑 required by `Podfile`

可以参考这篇文章:http://blog.csdn.net/pinxue/article/details/47162725 在私有仓库上做一个 pod 模块,一直好好的,一通折腾之后突然不对了,在 Example 里运行 pod install,居然报: Resolving de...
  • fg313071405
  • fg313071405
  • 2015-08-01 20:36
  • 18155

修复cocoapods - Unable to satisfy the following requirements:

修复cocoapods 2014-12-21 在拉下松爷更新的Podfile后,尝试用pod update更新,结果出现下面错误 $pod update Update all pods Analyzing dependencies [!] Unable to satisfy the fol...
  • happyrabbit456
  • happyrabbit456
  • 2015-04-23 18:27
  • 3572

Cocoapods-Unable to satisfy the following requirements

记录一个问题,之前遇到过,又忘了:Cocoapods 更新出现如下错误Resolving dependencies of `Podfile` [!] Unable to satisfy the following requirements: - `OCMock (= 3.2.1)` required...
  • AD_118
  • AD_118
  • 2016-08-29 17:58
  • 1793

Unable to satisfy the following requirements解决方案

Unable to satisfy the following requirements解决方案  2015-07-30 13:25 5498人阅读 评论(2) 收藏 举报  分类:   CocoaPods(7)...
  • YLGWHYH
  • YLGWHYH
  • 2016-07-07 15:38
  • 552

[!] Unable to satisfy the following requirements: - `AFNetworking (~> 2.6.1)` required by `Podfile`

错误描述控制台出现 如此错误:$ pod update Update all pods Updating local specs repositories Analyzing dependencies [!] Unable to satisfy the following requirements:...
  • yanyanforest
  • yanyanforest
  • 2016-01-22 10:05
  • 2353

[!] Unable to satisfy the following requirements:

[!] Unable to satisfy the following requirements: - `Alamofire (~> 4.0)` required by `Podfile` Specs satisfying the `Alamofire (~> 4.0...
  • CornerAndCorner
  • CornerAndCorner
  • 2016-09-29 15:41
  • 717
    文章分类
    最新评论