【poj 3159】Candies 差分约束+spfa(stack)

题目http://poj.org/problem?id=3159

Candies

Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 28008 Accepted: 7728

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4

Sample Output
5

Hint

32-bit signed integer type is capable of doing all arithmetic.

思路:差分约束系统,建边
b-a<=k
最大值建边,最短路;

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
int head[30005],to[150005],val[150005],nex[150005];
int q[30005];
int n,m;
int aa,bb,cc;
int vis[30005];
int d[30005];
int tot=0;
void add(int xx,int yy,int vv)
{
    int tmp=head[xx];
    head[xx]=++tot;
    to[tot]=yy;
    val[tot]=vv;
    nex[tot]=tmp;
}
void spfa(int st)
{
    int top=0;
    memset(d,-1,sizeof(d));
    q[++top]=st;
    d[st]=0;
    vis[st]=1;
    while(top)
    {
        int now=q[top--];

        vis[now]=0;
        for(int i=head[now];i!=-1;i=nex[i])
        {
            int v=to[i];
            int vv=val[i];
            if(d[v]==-1||d[v]>d[now]+vv)
            {
                d[v]=d[now]+vv;
                if(!vis[v])
                {
                    vis[v]=1;
                    q[++top]=v;
                }
            }
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    memset(head,-1,sizeof(head));
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&aa,&bb,&cc);
        add(aa,bb,cc);
    }
    spfa(1);
    cout<<d[n]<<endl;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值