POJ 2559(第三届河南省程序设计大赛F题(单调栈应用))

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21082 Accepted: 6787

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where  0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题解:题目大意:有些时候学习英语也是程序员的必经之路,所以自己去看吧。

           我的思路:单调栈水一发就过了。 如果不知道单调栈是什么可以去这个博客看看:文西的博客(其实我也是刚去学的大笑

下面是我的代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<map>
#include<algorithm>
#include<iostream>
#include<stack>
#include<vector>
#define ll long long
using namespace std;

const int maxn = 100005;
int n;
ll heights[maxn];
struct node
{
    ll height;  // 高度
    int startindex; // 满足该高度的最先出现的位置
    node(ll _height, int _index):height(_height), startindex(_index){};
};
ll getmaxarea()
{
    stack<node> s;
    s.push(node(-1, 0));
    ll height1, currentarea, maxarea = 0;
    int currentposition;
    for(int i = 0; i <= n; i++)
    {
        currentposition = i+1;
        if(i == n)
            height1 = 0;
        else
        height1 = heights[i];
        node cur(height1, currentposition);
        while(height1<s.top().height) // pop所有比当前高度大的节点
        {
            cur = s.top();
            s.pop();
            currentarea = (currentposition-cur.startindex)*cur.height;
            maxarea = max(maxarea, currentarea);
        }
        s.push(node(height1, cur.startindex)); //入栈
    }
    return maxarea;
}
int main()
{
    while(~scanf("%d", &n) && n)
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%lld", heights+i);
        }
        printf("%lld\n", getmaxarea());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值