POJ1001&HDU1063

29 篇文章 0 订阅

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 107685 Accepted: 26199

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 

接触的大数和高精度处理的题比较少,就试了下这道题,A的挺意外的,一遍过了。主要还是细节问题吧。

之后我又提交了杭电的1063,发现POJ的数据太弱了

大概这几组我之前的程序都是通不过的

000000 1

0.0000 1

000010 1

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
int array[155];
bool flag;
int main()
{
    char a[6];
    int b;
    while(~scanf("%s%d",a,&b))
    {
        if(b==0)
        {
            printf("1\n");
            continue;
        }
        int lx;
        int i=5;
        int z;
        flag=0;
        for(z=0; z<6; z++) if(a[z]=='.') flag=1;
        for(z=0; z<6; z++)
            if(a[z]!='0'&&a[z]!='.') break;
        if(z==6)
        {
            printf("0\n");
            continue;
        }
        if(flag)
            while(a[i]=='0'&&i>=0)
                i--;
        int j=0;
        while(a[j]!='.'&&j<6)
            j++;
        lx=(i-j)*b;
        int c=0,p=1;
        for(; i>=0; i--)
        {
            if(a[i]!='.')
            {
                c+=p*(a[i]-'0');
                p*=10;
            }
        }
        memset(array,0,sizeof(array));
        array[0]=1;
        for(i=1; i<=b; i++)
        {
            int t=0;
            for(j=0; j<154; j++)
            {
                int tmp=array[j]*c+t;
                array[j]=tmp%10;
                t=(tmp/10);
            }
        }
        for(i=154; i>=0; i--)
            if(array[i]) break;
        if(i<=lx-1)
        {
            int tmp=lx-1-i;
            printf(".");
            for(j=0; j<tmp; j++)
                printf("0");




            for(; i>=0; i--)
                printf("%d",array[i]);
            printf("\n");
        }
        else if(i>lx-1)
        {
            for(; i>=0; i--)
            {
                if(i==lx-1) printf(".");
                printf("%d",array[i]);
            }
            printf("\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值