【hdu1312】red and black——bfs

题目:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15251    Accepted Submission(s): 9445


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source


描述:给一个房间,地砖分可走不可走,选一个可走的初始位置,不能斜着走,求从初始位置最多能到多少块地砖

题解:经典的bfs,搜到一块就标记一块,然后计数器自加

代码:

#include <iostream>
#include <queue>
#include <cstring>
#include <algorithm>
#define CLR0(a) (memset(a,0,sizeof(a)))
using namespace std;
const int maxn = 50;
queue<pair<int, int>> q; //bfs用的队列
bool vis[maxn][maxn];    //标记是否被访问过的数组
int cnt;				 //记录答案
char map[maxn][maxn];	 //输入的地图
void init()              //初始化
{
	CLR0(vis); CLR0(map);
	if (!q.empty())q.pop();  //清空队列
	cnt = 1;
}
int dx[] = { -1,0,1,0 };    //用于枚举上下左右四个方向
int dy[] = { 0,1,0,-1 };	
int main()
{
	int w, h;
	while (cin >> w >> h && w)
	{
		init();			//先初始化 先初始化 先初始化
		for (int i = 0; i < h; i++)
			scanf("%s", map[i]);
		for (int i = 0; i < h; i++)
			for (int j = 0; j < w; j++)
				if (map[i][j] == '@')
				{
					q.push(make_pair(i, j)); //找到起点后,将其加入队列
					vis[i][j] = 1;			 //标记起点已访问
					break;
				}
		int x, y, X, Y;
		while (!q.empty())  //队列非空时都该继续搜索
		{
			x = q.front().first;			//从队列中取出一个元素
			y = q.front().second;			
			q.pop();
			for (int i = 0; i < 4; i++)
			{
				X = x + dx[i]; Y = y + dy[i];		//X、Y是从x、y出发,经过移动的新坐标
				//如果  1.坐标不在地图范围内  2.该点是红色的  3.该点已访问  则忽略该点
				if (X < 0 || X >= h || Y < 0 || Y >= w || map[X][Y] != '.' || vis[X][Y])continue;
				//不满足忽略条件,说明是我们要找的点
				vis[X][Y] = 1;   //标记为已访问
				cnt++;			 //答案+1
				q.push(make_pair(X, Y));	//将该点加入队列
			}
		}
		printf("%d\n", cnt);

	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值