XDOJ1207 - love message

Description

 Jiangshan and Zhao Yiran is a sweetheart lover in different class. So, Jiangshan developed a application to send message to Zhao Yiran through wireless. However, so unfortunately, their teachers are so great that all they send will be received by their teachers too. In order to keep their message secrecy, they have to encrypt the message.

 

When a char X appear n times, Jiangshan will show it as Xn, for example bb->b2. In order to get the love message, Zhao Yiran have to deciphering the message with mind acts upon mind. Could you help they to deciphering.

Input

 A string S, indicates the message Zhao Yiran get, all the char is lower case. There may be several test cases in the input file and end when S equal to XXX.

Output

A string T, indicates the message after deciphering.

Sample Input

a3
go12gle
XXX

Sample Output

aaa
goooooooooooogle

解题思路:

非常简单的字符串处理

#include<iostream>
#include<string>
using namespace std;

int main()
{
    string str;
    string over = "XXX";
    string ans;
    while(cin>>str)
    {
        if(str==over)
            break;
        int len = str.length();
        ans = "";
        for(int i=0;i<len;)
        {
            char ch;
            if(str[i]>='0'&&str[i]<='9')
            {
                ch = str[i-1];
                int t = str[i]-'0';
                ++i;
                while(str[i]>='0'&&str[i]<='9')
                {
                    t *= 10;
                    t += str[i]-'0';
                    ++i;
                }
                for(int j=1;j<t;++j)
                    ans += ch;
            }
            else
            {
                ans += str[i];
                ++i;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

最后欢迎大家访问我的个人网站: 1024s

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值