HDU 1003 Max Sum【区间最大值】题解

HDU 1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

Author
Ignatius.L

题目意思大致为编写一个程序计算最大区间和。
例如:

0 6 -1 1 -6 7 -5
这组数据中从1到6的区间和最大,为7。

这道题的做法有2种:

1、二层for循环(会超时)

for i 0 to n
    for j i to n
 ij表示左右端点

然后去算哪个最大。

2、一层for循环

思路是这样的,首先让sum等于arr[0](初始化),然后判断sum是否为负数。
如果为负数,表明后面的数字加上sum不能让接下来的区间和变大,于是便舍弃sum,让sum从当前位置开始计算;
否则sum为正数则可以使得接下来的区间变大,可以继续计算。

只不过这样并不能保证统计出的sum是最大值,每次循环的时候都需要跟maxm比较一下大小,如果maxm小于count,那么就让maxm等于sum。

maxm=sum=arr[0]
for i 1 to n
    if(sum<0)
        sum+=arr[i]
    else
        sum=arr[i]
    maxm=max(sum,maxm)

不过这一提要求记录一下起点和终止点,区别也不大,记录一下就可以了。(记得最后加个1)

AC代码:

#include<cstdio>
#define maxn 200005
int main(){
    int t,n,l=0;
    int arr[maxn];
    scanf("%d",&t);
    while(t--){
        if(l)
            printf("\n");
        scanf("%d",&n);
        int sum,now,st,ed,ast,aed;
        for(int i=0;i<n;++i)
            scanf("%d",arr+i);
        now=sum=arr[0];
        st=ed=ast=aed=0;
        for(int i=1;i<n;++i){
            if(sum<0){
                sum=arr[i];
                st=ed=i;
            }else{
                sum+=arr[i];
                ed=i;
            }
            if(sum>now){
                now=sum;
                ast=st;
                aed=ed;
            }

        }
        printf("Case %d:\n%d %d %d\n",++l,now,ast+1,aed+1);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值