POJ 2109 Power of Cryptography

不知道那里贪心了。。。学长说贪心。

注意:数据类型范围,还是不太了解;

原题链接:http://poj.org/problem?id=2109

Power of Cryptography
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13983 Accepted: 7136

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source

各种数据类型范围:

unsigned   int   0~4294967295   
int   2147483648~2147483647 
unsigned long 0~4294967295
long   2147483648~2147483647
long long的最大值:9223372036854775807
long long的最小值:-9223372036854775808
unsigned long long的最大值:1844674407370955161

__int64的最大值:9223372036854775807
__int64的最小值:-9223372036854775808
unsigned __int64的最大值:18446744073709551615


float 32 6~7 10^(-37) ~  10^38
double 64 15~16 10^(-307)   ~   10^308
long double 128 18~19 10^(-4931)  ~  10 ^ 4932

//Accepted	212K	0MS	C++	212B	2012-09-18 20:47:04
#include<cstdio>
#include<cmath>
int main()
{
    double n,p;
    double ans;
    while(scanf("%lf%lf",&n,&p)!=EOF)
    {
        ans=pow(p,1/n);
        printf("%.0lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值