【POJ 3254】 Corn Fields(状压DP)

【POJ 3254】 Corn Fields(状压DP)


Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10891 Accepted: 5705

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source


题目大意是有一个M*N的牧场,农夫FJ要在上面种草给牛吃。但他不想让任何两个牛挨着吃,也就是种的任何两颗草不能相邻。

给出的牧场值为1的地方可以种草,2不可以种。

问最多多少种种法


典型的状压DP 一维表示行,二维用二进制表示状态。从上往下DP即可 每次判断一下当前行是否合法,还有与前一行组合是否合法

最后统计输出全部状态即可


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int mod = 1e8;
const int msz = 10000;
const double eps = 1e-8;

LL dp[2][33333];
int mp[23][33];
int m,n;

bool can(int i,int j)
{
	bool pre = 0;
	for(int k = 0; k < n; ++k)
	{
		if(j&1 && (!mp[i][k] || pre)) return false;
		pre = j&1;
		j >>= 1;
	}
	return true;
}

int main()
{
	while(~scanf("%d%d",&m,&n))
	{
		for(int i = 0; i < m; ++i)
			for(int j = 0; j < n; ++j)
				scanf("%d",&mp[i][j]);

		int tot = 1<<n;
		memset(dp,0,sizeof(dp));
		for(int i = 0; i < tot; ++i)
		{
			if(can(0,i)) dp[0][i] = 1;
		}

		int pre = 1;
		for(int i = 0; i < m-1; ++i, pre ^= 1)
		{
			memset(dp[pre],0,sizeof(dp[pre]));
			for(int j = 0; j < tot; ++j)
			{
				if(!dp[pre^1][j]) continue;
				for(int k = 0; k < tot; ++k)
				{
					if(!can(i+1,k) || j&k) continue;
					dp[pre][k] = (dp[pre][k]+dp[pre^1][j])%mod;
				}
			}
		}

		LL ans = 0;
		for(int i = 0; i < tot; ++i) ans = (ans+dp[pre^1][i])%mod;
		printf("%lld\n",ans);
	}

	return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值