Adb failed to restart! Make sure the plugin is properly configured.

转载 2015年11月17日 21:41:31

目录(?)[+]
  1. 错误提示
  2. 产生原因
  3. 解决办法

错误提示:

今天我在运行项目的时候发现自己的手机连不上Eclipse,进入DDMS,adb reset之后出现了如下提示:

错误提示

产生原因:

出现这个错误的原因是因为电脑上的各种手机助手抢占了手机链接,用自己的adb进程启动,导致我们开发用的sdk abd无法启动。


解决办法:

知道原因后,解决办法就是手动在任务管理其中将各种手机助手的进程关闭(仅仅关闭退出他们的软件是不行的,必须杀掉他们的进程才可以的)。我们可以右键点击window下面的任务栏,然后选择“启动任务管理器”,然后在任务管理器中找到响应手机助手的进程,我的电脑上面装的是金山的手机助手,它的进程是:tadb.exe
金山手机助手进程
选中并结束这个进程即可
结束手机助手进程
最后我们在eclipse的DDMS中重新reset adb即可使手机连接上eclipse,over~

相关文章推荐

[转]Adb failed to restart! Make sure the plugin is properly configured.

错误提示:今天我在运行项目的时候发现自己的手机连不上Eclipse,进入DDMS,adb reset之后出现了如下提示:产生原因:出现这个错误的原因是因为电脑上的各种手机助手抢占了手机链接,用自己的a...

Cannot write to snapshot prefix '***'. Make sure that the directory exists and is writeable解决方法

Cannot write to snapshot prefix 'caffe/examples/mnist/lenet'. Make sure that the directory exists a...

contains dots but no replacement was configured!Make sure map keys don't contain dots in the first p

Map key 127.0.0.1:44444 contains dots but no replacement was configured! Make sure map keys don't co...

Android无法启动AVD解决方法出现"The connection to adb is down...You must restart adb and Eclipse."

Android无法启动AVD解决方法出现"The connection to adb is down...You must restart adb and Eclipse." 出现的错误信息具体如下:...
  • qiu_11
  • qiu_11
  • 2013年11月14日 17:47
  • 1421

使用ec编译cocos项目是出现Android.mk文件报错Are you sure your NDK_MODULE_PATH variable is properly defined 的解决办法

由于博主也是刚接触cocos游戏。懂得不是很多。现在只能慢慢把我遇到的一些问题和解决方法写出来,以便日后查阅,也分享给大家。下面写的内容有不足之处,也请大家指出。 博主今天在使用ec编译An...

Android NDK: Are you sure your NDK_MODULE_PATH variable is properly defined

运行Helloworld报错 Android NDK: jni/Android.mk: Cannot find module with tag 'cocos2dx' in import path  ...
  • bruce_Ke
  • bruce_Ke
  • 2012年07月26日 10:16
  • 19492

Qt:Application failed to start because platform plugin “windows” is missing.

今天,在新建一个Qt App的时候,编译新的工程就出现以下错误: 于是,我就一脸懵逼了,前几天还可以,今天砸门大姨妈了···,于是开始百度这个问题,发现他们说 plugin/platforms/下缺...

关于android studio出现Gradle sync failed: Plugin is too old, please update to a more recent version

今天打开as出现以下错误信息: Gradle sync failed: Plugin is too old, please update to a more recent version,or ...

Make Sure the Simple Stuff Is Simple

Make Sure the Simple Stuff Is SimpleChad LaVigneSoFTWARE ARCHiTECTS SolvE a lot of very difficult p...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Adb failed to restart! Make sure the plugin is properly configured.
举报原因:
原因补充:

(最多只允许输入30个字)