算法竞赛入门经典 第三章 uVA202 - Repeating Decimals

Repeating Decimals

The decimal expansion of the fraction 1/33 is tex2html_wrap_inline43 , where the tex2html_wrap_inline45 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.

tabular23

Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle.

In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins - it will begin within the first 50 places - and place ``...)" after the 50th digit.

Print a blank line after every test case.

Sample Input

76 25
5 43
1 397
Sample Output

76/25 = 3.04(0)
1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)

99 = number of digits in repeating cycle


#include<cstdio>
using namespace std;
int main()
{
	int a, b;
	while (scanf("%d%d", &a, &b) != EOF)
	{
		int n = a / b;//小数点前面位数
		int mod[10000];//用于存储每次求余的余数
		int after[100000];//用于存储小数点后面的位数
		int i, j, k;//计数变量
		int flag = 0;//标志变量 表示已找到循环节
		printf("%d/%d = ", a, b);
		for (i = 0; i < b ; i++)
		{
			a %= b;
			mod[i] = a;
			a *= 10;
			after[i] = 10 * mod[i] / b;
			for (j = 0; j < i; j++)
			{
				if (mod[j] == mod[i])
				{
					flag = 1;
					break;
				}
			}
			if (flag == 1)
				break;
		}
		printf("%d.", n);
		for (k = 0; k < j; k++)
		{
			printf("%d", after[k]);
		}
		printf("(");
		if (i - j > 50)
		{
			for (k = j; k < j+50; k++)
			{
				printf("%d", after[k]);
			}
			printf("...");
		}
		else
		{
			for (k = j; k < i; k++)
			{
				printf("%d", after[k]);
			}
		}
		printf(")\n");
		printf("   %d = number of digits in repeating cycle\n\n", i - j);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值