hdu 2795 Billboard(线段树单点更新)

Billboard

                                               Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15595    Accepted Submission(s): 6571



Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

题目大意:每张广告都是高度为1宽度为w的细长的矩形纸条。贴广告的人总是会优先选择最上面的位置来帖,而且在所有最上面的可能位置中,他会选择最左面的位置,而且不能把已经贴好的广告盖住。 如果没有合适的位置了,那么这张广告就不会被贴了。

 现在已知广告牌的尺寸和每张广告的尺寸,求每张广告被贴在的行编号。

解题思路:线段树单点更新。要特别注意h和n的关系,h是广告牌的高度,即线段树的容量,但n上界远远小于h,如果容量直接取h会RE,因此容量应取n和h的较小值。初始化所有节点为w,即每行能贴纸条的宽度。取区间最大值,即该高度区间里能贴纸条的最大宽度,如果该区间最大值小于当前纸条宽度,则不必再访问该区间。

代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const maxn=800005;
int tr[maxn];
int h,w,p;
void Query(int l,int r,int x,int root)
{
	if(l==r)  //线段树的结构特点就是单点从前往后的,即高度是从上往下的
	{
		if(tr[root]-x>=0)   //此行可以贴纸条,更新单点
		{
			tr[root]-=x;
			printf("%d\n",l);
			p=1;           //标记已贴过纸条
		}
		return ;
	}
	int mid=(l+r)/2;
	if(!p&&x<=tr[root*2])
		Query(l,mid,x,root*2);
	if(!p&&x<=tr[root*2+1])
		Query(mid+1,r,x,root*2+1);
	tr[root]=max(tr[root*2+1],tr[root*2]);
}
int main(void)
{
	int x,n;
	while(scanf("%d%d%d",&h,&w,&n)!=EOF)
	{
		h=h>n?n:h;  //不加这句会RE
		for(int i=0;i<maxn;i++)
			tr[i]=w;
		for(int i=0;i<n;i++)
		{
			p=0;
			scanf("%d",&x);
			if(tr[1]<x)
				printf("-1\n");
			else
				Query(1,h,x,1);
		}
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值