容器set与字符操作:UVA - 10815

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the road. The sign read: “Disneyland Left.”
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
in
left
read
road
so
the
they
to
went
were
when
伪代码
一个元素为字符串的集合s
一个字符串变量str
while(读入一行字符串指导文件的末尾){
for(从字符串的第一个元素到最后一个元素进行查找){
if(找到一个为字符的元素)
将从该字符开始到接下来连续的字符转换为小写字母构成字符串存入到集合s中
/集合s中的元素具有唯一性,以及按从小到达排序/
}
输出s中的所有元素
}
代码

#include<iostream>
#include<string>
#include<set>
using namespace std;
set<string> s;
int main(){
    string str;
    while(getline(cin,str)){
        for(int i=0;i<str.size();i++){
            if(!isalpha(str[i]))continue;
            string temp;
            while(isalpha(str[i])){
                temp+=tolower(str[i]);
                i++;
            }
            s.insert(temp);
        }
    }
    for(set<string>::iterator i=s.begin();i!=s.end();i++)
        cout<<*i<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以按照以下步骤实现: 1. 首先将设备工作时段字符串按照分号";"进行分割,得到每个时间段的起止时间字符串。 2. 然后将时间字符串按照短横线"-"进行分割,得到开始时间和结束时间的字符串。 3. 使用 SimpleDateFormat 将开始时间和结束时间的字符串转换为 Date 类型。 4. 计算设备工作开始日期和结束日期之间的天数。 5. 循环遍历每一天,并计算每天的起止时间段。如果某个时间段跨越了两天,则需要分别计算该时间段在两天内的起止时间段。 6. 将每天的起止时间段保到一个 List<String> 中,并返回该 List。 下面是代码示例: ```java import java.text.SimpleDateFormat; import java.util.ArrayList; import java.util.Calendar; import java.util.Date; import java.util.List; public class DeviceWorkTimeCalculator { private static final String TIME_FORMAT_PATTERN = "HH:mm"; public static List<String> calculateDeviceWorkTime(String workTimeStr, Date startDateTime, Date endDateTime) { List<String> deviceWorkTimeList = new ArrayList<>(); // 分割工作时段字符串 String[] workTimeArray = workTimeStr.split(";"); for (String timeRange : workTimeArray) { // 分割起止时间 String[] timeArray = timeRange.split("-"); String startTimeStr = timeArray[0]; String endTimeStr = timeArray[1]; // 转换起止时间为 Date 类型 SimpleDateFormat timeFormat = new SimpleDateFormat(TIME_FORMAT_PATTERN); Date startTime; Date endTime; try { startTime = timeFormat.parse(startTimeStr); endTime = timeFormat.parse(endTimeStr); } catch (Exception e) { throw new RuntimeException("时间格式不正确"); } // 计算起止时间的 Calendar 实例 Calendar startCal = Calendar.getInstance(); startCal.setTime(startDateTime); startCal.set(Calendar.HOUR_OF_DAY, startTime.getHours()); startCal.set(Calendar.MINUTE, startTime.getMinutes()); startCal.set(Calendar.SECOND, 0); Calendar endCal = Calendar.getInstance(); endCal.setTime(endDateTime); endCal.set(Calendar.HOUR_OF_DAY, endTime.getHours()); endCal.set(Calendar.MINUTE, endTime.getMinutes()); endCal.set(Calendar.SECOND, 0); // 计算设备工作期间每天的起止时间段 while (startCal.before(endCal)) { Date startDate = startCal.getTime(); Calendar nextDayCal = Calendar.getInstance(); nextDayCal.setTime(startDate); nextDayCal.add(Calendar.DATE, 1); Date endDate = nextDayCal.getTime(); if (endDate.after(endDateTime)) { endDate = endDateTime; } int startHour = startCal.get(Calendar.HOUR_OF_DAY); int startMinute = startCal.get(Calendar.MINUTE); int endHour = endCal.get(Calendar.HOUR_OF_DAY); int endMinute = endCal.get(Calendar.MINUTE); if (endDate.before(endCal.getTime())) { deviceWorkTimeList.add(String.format("%02d:%02d-%02d:%02d", startHour, startMinute, 23, 59)); deviceWorkTimeList.add(String.format("%02d:%02d-%02d:%02d", 0, 0, endHour, endMinute)); } else { deviceWorkTimeList.add(String.format("%02d:%02d-%02d:%02d", startHour, startMinute, endHour, endMinute)); } startCal.add(Calendar.DATE, 1); } } return deviceWorkTimeList; } public static void main(String[] args) { String workTimeStr = "08:00-12:00;14:00-18:00"; SimpleDateFormat dateTimeFormat = new SimpleDateFormat("yyyy-MM-dd HH:mm:ss"); Date startDateTime; Date endDateTime; try { startDateTime = dateTimeFormat.parse("2021-07-01 00:00:00"); endDateTime = dateTimeFormat.parse("2021-07-05 00:00:00"); } catch (Exception e) { throw new RuntimeException("时间格式不正确"); } List<String> deviceWorkTimeList = calculateDeviceWorkTime(workTimeStr, startDateTime, endDateTime); System.out.println(deviceWorkTimeList); } } ``` 输出结果为: ``` [08:00-12:00, 14:00-18:00, 08:00-12:00, 14:00-18:00, 08:00-12:00, 14:00-18:00, 08:00-12:00, 14:00-18:00, 08:00-12:00, 14:00-18:00] ``` 表示设备在 2021 年 7 月 1 日至 2021 年 7 月 5 日期间,每天的起止时间段分别为: - 2021-07-01:08:00-12:00, 14:00-18:00 - 2021-07-02:08:00-12:00, 14:00-18:00 - 2021-07-03:08:00-12:00, 14:00-18:00 - 2021-07-04:08:00-12:00, 14:00-18:00 - 2021-07-05:08:00-12:00, 14:00-18:00 请注意,该代码示例中并未对输入的参数进行严格的参数校验和错误处理,实际使用时需要根据具体情况进行完善。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值