POJ-1952 BUY LOW, BUY LOWER(线性DP)

BUY LOW, BUY LOWER
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9244 Accepted: 3226
Description

The advice to “buy low” is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems’ advice:
“Buy low; buy lower”

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:
Day 1 2 3 4 5 6 7 8 9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87

The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:
Day 2 5 6 10

Price 69 68 64 62
Input

  • Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

  • Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.
    Output

Two integers on a single line:
* The length of the longest sequence of decreasing prices
* The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they “look the same” when the successive prices are compared. Thus, two different sequence of “buy” days could produce the same string of decreasing prices and be counted as only a single solution.
Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87
Sample Output

4 2

关键是判断最长下降子序列有多少个,要用两个状态数组,一个是求最长下降子序列,一个求个数,注意判重

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
#define MAX 5000
int dp[MAX+5];
int cnt[MAX+5];
int n;
int a[MAX+5];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        a[n]=-1;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
        {
            int num=0;
            for(int j=i-1;j>=0;j--)
            {
                if(a[j]>a[i])
                {
                    if(num<dp[j])
                        num=dp[j];
                }
            }
            dp[i]=num+1;
        }
        memset(cnt,0,sizeof(cnt));
        bool tag;
        for(int i=0;i<=n;i++)
        {
            if(dp[i]==1)
            {
                cnt[i]=1;continue;
            }
            for(int j=i-1;j>=0;j--)
            {

                if(a[j]>a[i]&&dp[j]==dp[i]-1)
                {
                    tag=true;
                    for(int k=j+1;k<i;k++)
                        if(a[k]==a[j])
                        {
                            tag=false;
                            break;
                        }
                    if(tag)
                        cnt[i]+=cnt[j];

                }

            }
        }
        printf("%d %d\n",dp[n]-1,cnt[n]);

    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值