【poj1222】EXTENDED LIGHTS OUT 模拟

15 篇文章 0 订阅
7 篇文章 0 订阅

EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11892 Accepted: 7624

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1


题意:给你一个5行6列的由按钮组成的矩阵,每个按钮上有一个灯。按一次按钮灯本身以及上下左右共五个灯状态改变(亮的灯灭,灭的灯亮)。给你一个初始状态,问你怎么按使灯全灭。

输入:第一行是一个正整数N,表示需要解决的案例数。每个案例由5行组成,每一行包括6个数字。这些数字以空格隔开,可以是0或1。0表示灯的初始状态是熄灭的,1表示灯的初始状态是点亮的。

输出:输出:对每个案例,首先输出一行,输出字符串“PUZZLE #m”,其中m是该案例的序号。接着按照该案例的输入格式输出5行,其中的1表示需要把对应的按钮按下,0则表示不需要按对应的按钮。每个数字以一个空格隔开。

 

如果我们枚举每一个灯开还是关就是2^30显然不可行。我们就要想该如何优化使枚举数尽可能的变小。我们先假设第一列已经固定了。那么想要改变第一列的状态只能通过改变第二列的状态。如果第一列有灯没关,在第二列的同一行这个按钮必须按下。以此类推,如果第一列确定,那么后面每一列就已经确定了。所以我们只需要枚举第一列即可,瞬间缩到2^5=32次。

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int dx[4]={0,0,1,-1},dy[4]={1,-1,0,0},a[10][10],cur[10][10],res[10][10];
int n,T,t,tot;

void press(int x,int y)
{
    cur[x][y]=1-cur[x][y];
    for (int i=0;i<4;i++)
        if (x+dx[i] >= 0 && x+dx[i] < 5 && y+dy[i] >= 0 && y+dy[i] < 6)
            cur[x+dx[i]][y+dy[i]]=1-cur[x+dx[i]][y+dy[i]];
}
void write()
{
    cout<<"PUZZLE #"<<t<<endl;
    for (int i=0;i<5;i++)
    {
        for (int j=0;j<6;j++)
        {
            cout<<res[i][j];
            if (j<5) cout<<' ';
        }
        cout<<endl;
    }
}
bool judge()
{
    bool f=true;
    for (int j=1;j<6;j++)//这一点要注意,j循坏要在i循环之外,因为你只有将上一列的状态改变完了才能进入下一列。
        for (int i=0;i<5;i++)
            if (cur[i][j-1]) press(i,j),res[i][j]=1;
    for (int i=0;i<5;i++)
        if (cur[i][5]) f=false;
    return f;
}
int main()
{
    cin>>T;
    for (t=1;t<=T;t++)
    {
        for (int i=0;i<5;i++)
            for (int j=0;j<6;j++)
                cin>>a[i][j];
        for (int k=0;k<32;k++)//对于第一列的枚举我们转化为二进制,1表示按,0表示不按。
        {
            int p=k;tot=0;
            memset(res,0,sizeof(res));
            for (int i=0;i<5;i++)
                for (int j=0;j<6;j++)
                    cur[i][j]=a[i][j];
            for (int i=0;i<5;i++)
            {
                if (p&1) press(i,0),res[i][0]=1;
                p>>=1;
            }
            if(judge()) {write();break;}
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值