最小生成树 prim POJ 2349解题报告

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13809 Accepted: 4443
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13

用c++提交,不用G++

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define MAXN 505
#define INF 0xffffff
using namespace std;
int satelliteNum,outpostsNum;
int X[MAXN];//X[i]=1表示点i在最小生成树上
double DisX[MAXN];//DisX[i]表示点i(非生成树点)到生成树所有点的最短距离
double SideInTree[MAXN];//记录生成树上的线段长度
double G[MAXN][MAXN];
struct point{
    double x,y;
    point(){
        x=0;y=0;
    }
}Point[MAXN];
double GetDis(point a,point b){
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void Pri(){
    memset(X,0,sizeof(X));
     X[1]=1;
    for(int i=2;i<=outpostsNum;i++) DisX[i]=G[i][1];
    int SideNum=outpostsNum-1;
    int nextPoint;//下一个将要被加进生成树的点
    while(SideNum--){
        double minPath=INF;
        for(int i=2;i<=outpostsNum;i++){
            if(!X[i]&&DisX[i]<minPath){//在当前距离中找到最小值
                nextPoint=i;
                minPath=DisX[i];
            }
        }
        X[nextPoint]=1;//将最短距离对应的不在生成树上的点加进生成树
        SideInTree[SideNum]=minPath;
        for(int i=1;i<=outpostsNum;i++){//更新不在生成树的所有点的DisX
            if(!X[i]&&DisX[i]>G[nextPoint][i])
                DisX[i]=G[nextPoint][i];
        }
    }
}
int main()
{
    freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    int tests;
    scanf("%d",&tests);
    while(tests--){
        scanf("%d%d",&satelliteNum,&outpostsNum);
        for(int i=1;i<=outpostsNum;i++) scanf("%lf%lf",&Point[i].x,&Point[i].y);
        for(int i=1;i<=outpostsNum;i++){
            for(int j=1;j<=outpostsNum;j++){
              if(j>i)  G[i][j]=GetDis(Point[i],Point[j]);
               else  G[i][j]=G[j][i];//减少计算量
            }
            G[i][i]=0;
        }
        Pri();
        sort(SideInTree,SideInTree+outpostsNum-1);
        printf("%.2lf\n",SideInTree[outpostsNum-1-satelliteNum]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值