POJ 1125 Stockbroker Grapevine Floyd储存所有最短路并求其最长路径


Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24189 Accepted: 13302

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source


题意是说股票经纪人都愿意传谣言,每个股票经纪人只相信熟人说的话,传谣言也需要时间,告诉这些股票经纪人中的一个人一条谣言,他就会把这条传出去,如何选择这个人,使得其他人都会知道,而且最后那个人知道的时间最早。
最短路径问题。用Floyd会将所有的最短路径都存下来,然后你需要找到最短路径的源点,因此你需要遍历一遍所有点为源点,然后找出每个源点的最短路径中最长的那条路,最后求这些所有的最长路径中的最小值即可。如果图不连通,那么输出disjoint。

#include<stdio.h>
#define M 107
#define inf 0x3f3f3f
int g[M][M];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)//初始化
        {
            for(int j=1;j<=n;j++)
            {
                g[i][j]=inf;
            }
        }
        int num,a,b;
        for(int i=1;i<=n;i++)//建图
        {
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d%d",&a,&b);
                g[i][a]=b;
            }
        }
        for(int k=1;k<=n;k++)//Floyd
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(i!=j&&g[i][k]+g[k][j]<g[i][j])
                        g[i][j]=g[i][k]+g[k][j];
                }
            }
        }
        int minn=inf,max_lenth,source;
        for(int i=1;i<=n;i++)
        {
            max_lenth=0;
            for(int j=1;j<=n;j++)//每条路径中最长的路
                if(i!=j&&max_lenth<g[i][j])
                    max_lenth=g[i][j];
            if(minn>max_lenth)//所有最长路径中最短的路
            {
                minn=max_lenth;
                source=i;//记录源点
            }
        }
        if(minn<inf)
            printf("%d %d\n",source,minn);
        else
            printf("disjoint\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值