【主席树】POJ 2014 K-th Number

POJ 2014 K-th Number


Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.


Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).


Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.


Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3


Sample Output

5
6
3


HINT

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.


Solution

题意就是给你一个数组然后求其中一段区间的第k大
离散一下吧。。
然后貌似可以分块?(并不行)
这里介绍另外一种算法

主席树:
一种神奇的方法
首先每个节点建一棵树,每个点权值是前k个元素在该点管辖范围[L,R]之间的元素个数(也可以说前缀和)
然而这样建树是n^2logn的空间?
我们发现,每次加一个元素,只会修改树的左子树或者右子树.
所以每次使用一下之前的树即可,空间优化到nlogn.
询问[l,r]区间第k大时二分一下即可.

Code

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;

#define maxn 100001

struct node{
    int l,r,v;
}t[maxn*20];

inline int in()
{
    int x=0,f=1;char ch=getchar();
    while((ch<'0'||ch>'9')&&ch!='-')ch=getchar();
    if(ch=='-')ch=getchar(),f=-1;
    while(ch<='9'&&ch>='0')x=x*10+ch-'0',ch=getchar();
    return x*f;
}

int a[maxn],p[maxn],b[maxn],size,root[maxn];

bool cmp(const int A,const int B){return a[A]<a[B];}

void update(int &poi,int l,int r,int num)
{
    t[++size]=t[poi];poi=size;
    t[size].v++;
    if(l==r)return;
    int mid=(l+r)>>1;
    if(num>mid)update(t[poi].r,mid+1,r,num);
    else update(t[poi].l,l,mid,num);
}

int query(int L,int R,int l,int r,int k)
{
    if(l==r)return l;
    int T=t[t[R].l].v-t[t[L].l].v;
    int mid=(l+r)>>1;
    if(T>=k)return query(t[L].l,t[R].l,l,mid,k);
    else return query(t[L].r,t[R].r,mid+1,r,k-T);
}

int main()
{
    freopen("2104.in","r",stdin);
    int n,m,x,y,k;
    n=in(),m=in();
    for(int i=1;i<=n;i++)a[i]=in(),p[i]=i;
    sort(1+p,p+n+1,cmp);
    for(int i=1;i<=n;i++)b[p[i]]=i;
    for(int i=1;i<=n;i++)
    {
        root[i]=root[i-1];
        update(root[i],1,n,b[i]);
    }
    for(int i=1;i<=m;i++)
    {
        x=in(),y=in(),k=in();
        int X=query(root[x-1],root[y],1,n,k);
        printf("%d\n",a[p[X]]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值