【Jason's_ACM_解题报告】Prime Ring Problem

Prime Ring Problem 

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers  1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input 
n (0 < n <= 16)

Output 
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.

You are to write a program that completes above process.

Sample Input 
6
8

Sample Output 
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

从解答树的角度讲,回溯法正是按照深度优先的顺序在遍历解答树,所以,函数体以dfs命名并非巧合或是错误。

附代码如下:
#include<cstdio> 
#include<cstring>

using namespace std;

#define MAXN (20)
#define CLR(x,y) (memset(x,y,sizeof(x)))

int n;
int A[MAXN];
bool vis[MAXN],isprime[MAXN];

bool is_prime(int x){
	for(int i=2;i*i<=x;i++){
		if(x%i==0)return false;
	}
	return true;
}

void dfs(int current){
	if(current==n&&isprime[A[current-1]+A[0]]){
		printf("1");for(int i=1;i<n;i++)printf(" %d",A[i]);printf("\n");
	}else{
		for(int i=2;i<=n;i++){
			if(!vis[i]&&isprime[i+A[current-1]]){
				A[current]=i;
				vis[i]=true;
				dfs(current+1);
				vis[i]=false;
			}
		}
	}
}

int main(){
	int K=0;
	for(int i=2;i<40;i++)isprime[i]=is_prime(i);
	while(scanf("%d",&n)==1){
		if(K)printf("\n");
		printf("Case %d:\n",++K);
		CLR(vis,false);
		CLR(A,0);
		A[0]=1;
		dfs(1);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值