HDOJ 1003 经典DP--求最大字串和

题目链接:点击打开链接

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 242314    Accepted Submission(s): 57209


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

具体代码实现:

/*
	简单动态规划问题:
	
*/
import java.util.*;
class Main{
	public static void main(String args[]){
		Scanner sc=new Scanner(System.in);
			int n=sc.nextInt();
			for(int i=1;i<=n;i++){
				int m=sc.nextInt();
				int start=1;					//初始化起始位置为1
				int end=1;						//结束位置也是1
				int max=-1;
				int sum=0;
				int t=1;								//标记位置为第一项
				for(int j=1;j<=m;j++){
					int x=sc.nextInt();
					sum=sum+x;
					if(sum>max){
						max=sum;
						start=t;
						end=j;
					}
					if(sum<0){
						t=j+1;		//当前面几项的和小于0时,令标记位置为下一项也就是j+1
						sum=0;
					}
				}
				System.out.println("Case "+i+":"+"\r\n"+max+" "+start+" "+end);
				if(i!=n){
					System.out.println();
				}
			}
	}
}
/*
	为什么sum<0,就舍弃,重新开始扫描呢?我的想法是:

我用start表示子序列的起始下标,end?表示子序列的终止下标。
原理是,当我们得到一个子序列,如果子序列的第一个数是非正数,那么可以舍去.
当一个子序列的前n个元素和为非正数时,是否也可以舍去呢?答案是可以的。
假设k是i到j中任意一个下标。Sum( a, b )表示子序列第a个元素到第b个元素之和。由于加到第j个元素,
子序列才开始为负数,所以Sum( i, k ) > 0,Sum( i, k ) + Sum( k, j ) = Sum( i, j ) ,所以Sum( k, j ) < Sum( i, j ) < 0
所以如果把?k到j的序列附加到j之后的序列上,只会使序列越来越小。所以i到j的序列都可以舍去。

*/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值