A strange lift(简单BFS)

171 篇文章 0 订阅
99 篇文章 0 订阅

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12025    Accepted Submission(s): 4578


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5 3 3 1 2 5 0
 

Sample Output
  
  
3
 
code:
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int vis[222],n,a[222];
struct node{
int x;
int sp;
}st,ed;
int bfs()
{
memset(vis,0,sizeof(vis));
queue<node>Q;
node now,next;
int i;
st.sp=0;
Q.push(st);
vis[st.x]=1;
while(!Q.empty())
{
now=Q.front();
if(now.x==ed.x)
return now.sp;
Q.pop();
for(i=1;i<=2;i++)
{
switch(i)
{
case 1:
{
next.x=now.x+a[now.x];
if(next.x>0&&next.x<=n&&!vis[next.x])
{
next.sp=now.sp+1;
if(next.x==ed.x)
return next.sp;
Q.push(next);
vis[next.x]=1;
}
break;}
case 2:
{
next.x=now.x-a[now.x];
if(next.x>0&&next.x<=n&&!vis[next.x])
{
next.sp=now.sp+1;
if(next.x==ed.x)
return next.sp;
Q.push(next);
vis[next.x]=1;
}
break;}
}
}
}
return -1;
}
int main()
{
int i,ans;
while(1)
{
scanf("%d",&n);
if(n==0)
break;
scanf("%d%d",&st.x,&ed.x);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
ans=bfs();
printf("%d\n",ans);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值