Til the Cows Come Home(最短路(单源SPFA))

95 篇文章 0 订阅
63 篇文章 0 订阅



Link:http://poj.org/problem?id=2387


Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31889 Accepted: 10809

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source



AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#define LL long long
#define MAXN 20020
#define INF 9999999999
using namespace std;
int n,m;
LL d[MAXN];
struct node{
	int u,v,w;
	int next;
}E[MAXN];
bool vis[MAXN];
int head[MAXN];
int cnt[MAXN];
int tot;
void init()
{
	memset(head,-1,sizeof(head));
	tot=0;
}
void add(int uu,int vv,int ww)
{
	E[tot].u=uu;
	E[tot].v=vv;
	E[tot].w=ww;
	E[tot].next=head[uu];
	head[uu]=tot++;
}
bool spfa(int s,int n)
{
	queue<int>q;
	for(int i=0;i<=n;i++)
	{
		vis[i]=false;
		cnt[i]=0;
		d[i]=INF;
	}
	q.push(s);
	cnt[s]++;
	vis[s]=true;
	d[s]=0;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		if(cnt[u]>n)
			return false;
		for(int i=head[u];i!=-1;i=E[i].next)
		{
			int v=E[i].v;
			if(d[v]>E[i].w+d[u])
			{
				d[v]=d[u]+E[i].w;
				if(!vis[v])
				{
					q.push(v);
					vis[v]=true;
					cnt[v]++;
				}
			}
		}
	}
	return true;
}
int main()
{
	int u,v,w;
	while(cin>>m>>n)
	{
		init();
		while(m--)
		{
			cin>>u>>v>>w;
			add(u,v,w);
			add(v,u,w);//注意:因为是无向图,要双向加边 !!! 
		}
		spfa(n,n);//源点为n,终端为1 
		cout<<d[1]<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值