POJ 1562 Oil Deposits

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

水题。。。数连通块儿的,每次要记得初始化!,代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int d[8][2]={{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}};
int m,n;
char Map[105][105];
bool r[105][105];
bool ok(int x,int y)
{
    return x>=0&&x<m&&y>=0&&y<n&&Map[x][y]!='*'&&!r[x][y];
}
void DFS(int x,int y)
{
    for(int i=0;i<8;++i)
    {
        int u=x+d[i][0],v=y+d[i][1];
        if(ok(u,v))
        {
            r[u][v]=true;
            DFS(u,v);
        }
    }
}
int main()
{
    int sum;
    while(cin>>m>>n&&(m||n))
    {
        sum=0;
        memset(r,false,sizeof(r));
        memset(Map,0,sizeof(Map));
        for(int i=0;i<m;++i) {cin>>Map[i];}
        for(int i=0;i<m;++i)
        {
            for(int j=0;j<n;++j)
            {
                if(ok(i,j))
                {
                    DFS(i,j);
                    ++sum;
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值