poj2653 Pick-up sticks 计算几何 线段相交

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11634 Accepted: 4387

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.




只要(c x b) * (d x b) <= 0 && (e x a) * (f x a) <= 0,就说明两线段相交



#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>

using namespace std;

struct line {
	double x1, y1, x2, y2;
}e[100005];

int n;
bool inter[100005];

bool Intersect(line a, line b) {
	double cxb = (a.x2 - b.x1) * (b.y2 - b.y1) - (a.y2 - b.y1) * (b.x2 - b.x1);
	double dxb = (a.x1 - b.x1) * (b.y2 - b.y1) - (b.x2 - b.x1) * (a.y1 - b.y1);
	double exa = (b.x1 - a.x1) * (a.y2 - a.y1) - (b.y1 - a.y1) * (a.x2 - a.x1);
	double fxa = (b.x2 - a.x1) * (a.y2 - a.y1) - (a.x2 - a.x1) * (b.y2 - a.y1);
	if ((fabs(cxb * dxb) < 1e-10 || cxb * dxb < 0) && (fabs(exa * fxa) < 1e-10 || exa * fxa < 0)) {
		return true;
	}
	return false;
}

int main()
{
	while (~scanf("%d", &n) && n) {
		memset(inter, false, sizeof(inter));
		for (int i = 0; i < n; i++) {
			scanf("%lf%lf%lf%lf", &e[i].x1, &e[i].y1, &e[i].x2, &e[i].y2);
		}
		int cou = 0;
		for (int i = 0; i < n; i++) {
			for (int j = i + 1; j < n; j++) {
				if (Intersect(e[i], e[j])) {
					inter[i] = true;
					cou++;
					break;
				}
			}
		}
		cou = n - cou;
		printf("Top sticks: ");
		for (int i = 0, c = 0; i < n; i++) {
			if (!inter[i]) {
				c++;
				if (c == cou) {
					printf("%d.\n", i + 1);
					break;
				}
				else {
					printf("%d, ", i + 1);
				}
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值