HDU 1160 FatMouse's Speed (dp+路径记录)

传送门:点击打开链接

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16972    Accepted Submission(s): 7507
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7

题意是让求体重严格递增,速度严格递减的老鼠,并且输出老鼠的位置,表示没看到Special Judge,一直调不出示例结果,后来觉得自己很对,提交竟然A到。


可以按照体重递增排序,用dp[i]数组表示前i个老鼠中,有多少个是符合题目要求的,用path数组记录当前数组的前一个的值,使用结构体记录老鼠的初始位置。path数组初始化为每一个老鼠都只能到达本身,最后倒序输出。典型的dp模板题,就是多了路径记录。


代码实现:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>

using namespace std;
const int maxn=1e5+5;
struct mouse{
	int weight;
	int feed;    //英语不好,不要在意细节,好像应该是speed 
	int count;
}p[maxn];

int cmp(mouse a,mouse b)
{
	if(a.weight==b.weight)
	return a.feed<b.feed;
	
	return a.weight<b.weight;
}

int dp[maxn],path[maxn],ans[maxn];

int main()
{
	int i=0,j,k=0;
	while(cin>>p[i].weight)
	{
		cin>>p[i].feed;
		p[i].count=++k;
		i++;
	}
	
	memset(dp,0,sizeof(dp));
	sort(p,p+i,cmp);
	int n=i;
	for(i=0;i<n;i++)
	path[i]=i;
	
	int maxx=-1,index=0;
	for(i=0;i<n;i++)
	{
		dp[i]=1;
		for(j=0;j<i;j++)
		{
			if(p[i].weight>p[j].weight&&p[i].feed<p[j].feed&&dp[i]<dp[j]+1)
			{
				dp[i]=dp[j]+1;
				path[i]=j;
				
				if(dp[i]>maxx)
				{
					maxx=dp[i];
					index=i;
				}
			}
		}
	}
	
	
	cout<<maxx<<endl;
	k=0;
	while(path[index]!=index)
	{
		ans[k++]=p[index].count;
		index=path[index];
	}
	ans[k++]=p[index].count;
	for(i=k-1;i>=0;i--)
	cout<<ans[i]<<endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值