HDU 1078 FatMouse and Cheese (记忆化搜索)

传送门:点击打开链接

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10811    Accepted Submission(s): 4598


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37

题意是老鼠在n*n的一个矩阵里,老鼠一次可以走1到k的任意步,但每一步都要走比当前所处位置值大,问最后最大值的和是多少。


记忆化搜索的模板题,从起点到终点,dp的过程就是在去重,防止搜索多次超时问题。dp数组还顺便起到了标记的作用,每次记录搜索到的最大值,如果符合题意,就在最后加上它,最后需要返回搜索值。


代码实现:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#define ll long long

using namespace std;
const int maxn=105;

int dp[maxn][maxn],map[maxn][maxn]; //dp[x][y]储存从(1,1)到当前点的最大值,顺便起标记作用 
int dir[4][2]={0,1,1,0,0,-1,-1,0};  //方向数组 
int n,k;

int dfs(int x,int y)
{
	int i,j,l,ans=0;
	if(dp[x][y]==0)  //未走过 
	{
		for(i=1;i<=k;i++)   //枚举k步 
		{
			for(j=0;j<4;j++)
			{
				int tx=x+dir[j][0]*i;
				int ty=y+dir[j][1]*i;
				
				if(tx<1||ty<1||tx>n||ty>n)  //越界判断 
				continue;
				
				if(map[tx][ty]>map[x][y])   //找到比当前点大的点 
				ans=max(ans,dfs(tx,ty));
			}
		}
		dp[x][y]=ans+map[x][y];  //可以走各个中最大的那个+当前点的数值=当前点的最大值 
	}
	return dp[x][y]; //返回数值 
}

int main()
{
	int i,j;
	while(cin>>n>>k)
	{
		if(n<0&&k<0)
		break;
		
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		cin>>map[i][j];
		
		memset(dp,0,sizeof(dp));
		int ans=dfs(1,1); 
		cout<<ans<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值