HD 2438 Turn the corner (三分&&计算几何&&经典问题)

Turn the corner

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?


 

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.

 

Output
If he can go across the corner, print "yes". Print "no" otherwise.
 

Sample Input
  
  
10 6 13.5 4 10 6 14.5 4


Sample Output
   
   
yes no


思路
这是一个生活中比较常见的问题,已知汽车的长和宽,l和w,以及俩条路的宽为x和y,汽车所处道路宽为x ,问汽车能否顺利转弯?

分析:汽车能否顺利转弯取决于在极限情况下,随着角度的变化,汽车离对面路的距离是否大于等于0(即伸出长度小于等于y)

如下图中 满足:

s=l*cos(angle)+w*sin(angle)-x;
h=s*tan(angle)+w*cos(angle);

在转弯的过程中高度h先增大后减小(角度由pi/2 ->0 )三分时l=0,r=pi/2就好(相当于角度由0 -> pi/2时,h也是先增大后减小)
即满足单峰函数形式




代码示例
#include<bits/stdc++.h>
using namespace std;
#define eps 1e-6
const double pi=acos(-1.0);

double x,y,l,w;

double filter(double angle)
{
	double s=l*cos(angle)+w*sin(angle)-x;
	double h=s*tan(angle)+w*cos(angle);
	return h;
}

int main()
{
	while(scanf("%lf %lf %lf %lf",&x,&y,&l,&w)!=EOF)
	{
		double l=0,r=pi/2;
		double mid,midmid;
		while(r-l>eps)
		{
			mid=(l*2.0+r)/3.0;//采用除3形式
			midmid=(l+2.0*r)/3.0;
			if(filter(mid)>filter(midmid)) r=midmid;//极大值做法
			else l=mid;
		}
		if(filter(l)<=y) printf("yes\n");
		else printf("no\n");
	}
	return 0;
}



  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值