poj 1068 Parencodings

Parencodings

                        Time Limit: 1000MS      Memory Limit: 10000K

Total Submissions: 25474 Accepted: 14988
Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))

P-sequence      4 5 6666

W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题目大意:先给一个n,然后后面是n个数;
这个n个数,每个数分别代表当前有一个右括号,这个右括号前面有a[i]个左括号
求每个右括号与之相匹配的左括号之间有多少对成对的括号(包括他们自己)


#include <iostream>
#include <cstring>
#include <stack>

using namespace std;

bool vis[110];//用一个标记数组来标记一下右括号的位置

void Print(string s){
    char str[110];//用一个一个数组来模拟栈
    memset(str, false, sizeof(str));
    int top = 0;
    int len = s.length();
    bool flag = true;
    for (int i = 0; i < len; i++){
        if (vis[i]){//当前位置为右括号时就搜索前面的,直到找到与之相匹配的就退出
            //cout << top << endl;
            int count1 = 0;
            str[++top] = s[i];
            for (int j = i - 1; j >= 0; j--){
                if (s[j] == ')'){//遇到右括号就直接进栈
                    str[++top] = s[j];
                }
                else if (s[j] == '('){//遇到左括号就出栈,并记录一下个数
                    top--;
                    count1++;
                    if (top == 0){
                        if (flag){
                            cout << count1;
                            flag = false;
                            break;
                        }
                        else{
                            cout << ' ' << count1;
                            break;
                        }
                    }
                }
            }
        }
    }
    cout << endl;
}

int main(){
    int t;
    cin >> t;
    while (t--){
        int n;
        string s = "";
        cin >> n;
        int now;
        int x;//输入的数代表当前位置前面一共有x个左括号,然后是一个右括号
        cin >> x;
        for (int i = 0; i < x; i++) s += '(';
        now = x;
        s += ')';
        for (int i = 1; i < n; i++){
            cin >> x;
            for (int i = 0; i < x - now; i++) s += '(';
            s += ')';
            now = x;
        }
        memset(vis, false, sizeof(vis));
        for (int i = 0; i < s.length(); i++){//标记右括号位置
            if (s[i] == ')') vis[i] = true;
        }
//      for (int i = 0; i < s.length(); i++)
//            (i == s.length() - 1) ? (cout << vis[i] << endl) : (cout << vis[i] << ' ');
        Print(s);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值