BestCoder Round #63 (div.2) HDOJ5567 sequence1(暴力)

29 篇文章 0 订阅
9 篇文章 0 订阅

sequence1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 132    Accepted Submission(s): 103


Problem Description
Given an array  a  with length  n , could you tell me how many pairs  (i,j)  ( i < j ) for  abs(aiaj) mod b=c .
 

Input
Several test cases(about  5 )

For each cases, first come 3 integers,  n,b,c(1n100,0c<b109)

Then follows  n  integers  ai(0ai109)
 

Output
For each cases, please output an integer in a line as the answer.
 

Sample Input
  
  
3 3 2 1 2 3 3 3 1 1 2 3
 

Sample Output
  
  
1 2
 



题目链接:点击打开链接

注意到数据范围, 直接暴力计算即可.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
#include "utility"
#include "map"
#include "set"
#include "vector"
#include "list"
using namespace std;
typedef long long ll;
const int MOD = 1e9 + 7;
const int MAXN = 105;
int n, b, c, a[MAXN];
int main(int argc, char const *argv[])
{
	while(scanf("%d%d%d", &n, &b, &c) != EOF) {
		int ans = 0;
		for(int i = 0; i < n; ++i)
			scanf("%d", &a[i]);
		for(int i = 0; i < n - 1; ++i)
			for(int j = i + 1; j < n; ++j)
				if(abs(a[i] - a[j]) % b == c) ans++;
		printf("%d\n", ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值