【STL】 poj1208&&UVa101 The Blocks Problem (不定长数组vector的应用)

The Blocks Problem
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5920 Accepted: 2564

Description

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. 
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will "program" a robotic arm to respond to a limited set of commands. 
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0 <= i < n-1 as shown in the diagram below: 

The valid commands for the robot arm that manipulates blocks are: 

move a onto b 
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions. 


move a over b 
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions. 


pile a onto b 
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved. 


pile a over b 
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved. 


quit 
terminates manipulations in the block world. 

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks. 

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25. 
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered. 

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i ( 0 <= i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line. 

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input). 

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:
 
 
 
紫书STL不定长数组vector的例题 
题意:
从左到右n块木块,编号0~n-1,要求模拟以下四种操作:
1、move a onto b:先将a和b上方的木块放回原来的位置,然后将a摞在b上,
2、move a over b:先将a上方的木块放回原来的位罝,再将a放在b所在的那堆木块的顶部
3、pile a onto b:先将a上方的木块放回原来的位罝,将a和其上方的木块整体放到b的上面,
4、pile a over b:将a和其上方的木块整体放到b所在的那堆木块的顶部
quit结束命令,前四个操作中若a=b,或者a, b在同一堆中,是非法指令,应当忽略。
 
 
#include<cstdio>
#include<string>
#include<iostream>
#include<vector>
using namespace std;
#define N 30
int n;
vector<int>pile[N];
//找木块a所在的pile和height 以引用的形式返回调用值
void find_block(int a,int& p,int& h)
{
    for(p=0; p<n; p++)
    {
        for(h=0; h<pile[p].size(); h++)
            if(pile[p][h]==a)
                return ;
    }
}
//把第p堆高度为h的木块上方的所有木块移回原位
void clear_above(int p,int h)
{
    for(int i=h+1; i<pile[p].size(); i++)
    {
        int b=pile[p][i];
        pile[b].push_back(b);//push_back()在尾部加入一个数据 即把木块b放回原位
    }
    pile[p].resize(h+1);//第p堆只保留了0~h的元素  所以大小变为h+1
}
//把第p堆高度为h及其上方的木块移动到p2堆的顶部
void pile_onto(int p,int h,int p2)
{
    for(int i=h; i<pile[p].size(); i++)
    {
        pile[p2].push_back(pile[p][i]);
    }
    pile[p].resize(h);
}
int main()
{
    int a,b;
    string s1,s2;
    cin>>n;
    for(int i=0; i<n; i++)
        pile[i].push_back(i);//第i堆放i
    while(cin>>s1)
    {
        if(s1=="quit")
        {
            for(int i=0; i<n; i++)
            {
                printf("%d:",i);
                for(int j=0; j<pile[i].size(); j++)
                    printf(" %d",pile[i][j]);
                printf("\n");
            }
            break;
        }
        else
        {
            cin>>a>>s2>>b;
            int pa,pb,ha,hb;
            find_block(a,pa,ha);//查找元素a的位置
            find_block(b,pb,hb);//查找元素b的位置
            if(pa==pb)
                continue;
            if(s1=="move")//提取指令间的共同点
                clear_above(pa,ha);
            if(s2=="onto")
                clear_above(pb,hb);
            pile_onto(pa,ha,pb);
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值