【杭电OJ】1509--Windows Message Queue(优先队列)

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6006    Accepted Submission(s): 2449


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 

Author
ZHOU, Ran
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1512  1387  1710  1896  1403 
代码一:
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int pr,pa,num;
	char nam[42];
	bool friend operator < (node a,node b)
	{
		if(a.pr==b.pr)
		    return a.num>b.num;//优先级同,参数小先进 
		return a.pr>b.pr;//优先级不同 ,代表优先级的数值越小,优先级越大,所以数值从大到小排 
	}
 }da;
 int main()
 {
 	int a,b,sum=0;
 	char str[5];
 	priority_queue<node> q;//优先队列定义为结构体名称的node 类型,因为还要用到结构体里的pr,num,nam 
 	while(~scanf("%s",str))
 	{
 		if(str[0]=='P')
 		{
 			scanf("%s %d%d",da.nam,&a,&b);//将nam直接定义在结构体中 
 			da.pa=a;
 			da.pr=b;                          //只有一个队列,其实可以直接定义结构体里面的,比如: 
 			da.num=++sum;                      //scanf("%d%d",&da.pa,&da.pr); 
 			q.push(da);
		 }
		 else
		 {
		 	if(q.empty())
		 	    printf("EMPTY QUEUE!\n");
		 	else
		 	{
		 		da=q.top();
		 		q.pop();
		 		printf("%s %d\n",da.nam,da.pa);
			}
		 }
	 }
	 return 0;
 }
代码二:与一的区别就在于输入的一点,只有一个队列,就可以直接输入赋给结构体了;如果有多个队列,那可就要采用一的方法咯。
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int pr,pa,num;
	char nam[42];
	bool friend operator < (node a,node b)
	{
		if(a.pr==b.pr)
		    return a.num>b.num;//优先级同,参数小先进 
		return a.pr>b.pr;//优先级不同 ,代表优先级的数值越小,优先级越大,所以数值从大到小排 
	}
 }da;
 int main()
 {
 	int a,b,sum=0;
 	char str[5];
 	priority_queue<node> q;//优先队列定义为结构体名称的node 类型,因为还要用到结构体里的pr,num,nam 
 	while(~scanf("%s",str))
 	{
 		if(str[0]=='P')
 		{
 			scanf("%s %d%d",da.nam,&da.pa,&da.pr);//将nam直接定义在结构体中  
 			da.num=++sum;                      
 			q.push(da);
		 }
		 else
		 {
		 	if(q.empty())
		 	    printf("EMPTY QUEUE!\n");
		 	else
		 	{
		 		da=q.top();
		 		q.pop();
		 		printf("%s %d\n",da.nam,da.pa);
			}
		 }
	 }
	 return 0;
 }


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值