hdu3038--How Many Answers Are Wrong

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2829    Accepted Submission(s): 1084


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
  
  
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
  
  
1
 

Source
 

Recommend

带权并查集,考虑sum[i]表示i到根节点的和

每次对于l,r, 考虑fl, fr, 如果已经相同,说明关系已经确定
如果不同,考虑合并,以小的为根

/*************************************************************************
    > File Name: hdu3038.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月21日 星期三 22时03分59秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 200010; 
int sum[N];
int father[N];

void init (int n)
{
	for (int i = 0; i <= n; ++i)
	{
		father[i] = i;
		sum[i] = 0;
	}
}

int find (int x)
{
	if (x == father[x])
	{
		return x;
	}
	int fa = father[x];
	father[x] = find (father[x]);
	sum[x] += sum[fa];
	return father[x];
}

int main ()
{
	int n, m;
	int l, r, s;
	while (~scanf("%d%d", &n, &m))
	{
		init(n);
		int ans = 0;
		for (int i = 1; i <= m; ++i)
		{
			scanf("%d%d%d", &l, &r, &s);
			int fl = find(l - 1);
			int fr = find(r);
			if (fl == fr)
			{
				if (s != sum[r] - sum[l - 1])
				{
					++ans;
				}
			}
			else
			{
				if (fl < fr)
				{
					father[fr] = fl;
					sum[fr] = sum[l - 1] + s - sum[r];
				}
				else
				{
					father[fl] = fr;
					sum[fl] = sum[r] - sum[l - 1] - s; 
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值