Android studio 大BUG,Plugin is too old, please update to a more recent version

原创 2016年06月02日 11:04:40

一、背景

近阶段 在使用Android studio 时候 又报错  因为在Google I/O开发者大会(5月18至19日)后, 又有最新版本的 Android studio发布,发布版本号为 android studio 2.2


二、报错提示:

文字描述:

Error:(1, 0) Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to "e360e21d44786479c056da3409a98c2ea6f3a680"
<a href="fixGradleElements">Fix plugin version and sync project</a><br><a href="openFile:C:\Users\Nigel\Desktop\MyApplication\app\build.gradle">Open File</a>


图片描述:



三、解决方法:

其他博主的方法 有修改build.gralde  文件的,有降低 wrapper使用构建的。在这里 我强烈不建议使用,(这不是最好方法,有可能会失效,产生各种奇葩错误,到最后找BUG找的头疼)。


强烈建议,在Plugin  is  too old ,时请更新 Android studio 为最新版本即可

更新方法  第一, 去google官网(需翻墙)或 如下网站http://www.androiddevtools.cn/index.html#android-studio  下载最新版的android studio 请记住平台不能选错,

                 第二,删除掉 以前Android studio即可(Android studio在windows平台是免安装的,只需彻底删除相应的文件夹即可)

                 第三,解压最新Android studio 安装包,既可使用,即可解决Plugin is too old  问题。

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

关于android studio出现Gradle sync failed: Plugin is too old, please update to a more recent version

今天打开as出现以下错误信息: Gradle sync failed: Plugin is too old, please update to a more recent version,or ...

Error:(1, 0) Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRID

转载
  • gjy211
  • gjy211
  • 2016年03月07日 15:04
  • 948

The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.解决办法

MAC The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.解...
  • callzjy
  • callzjy
  • 2016年12月24日 02:44
  • 8768

This version of the rendering library is more recent than your version of ADT plug-in. Please update

最近使用 Help --> Check for Updates 升级了Eclipse部分插件,之后新建4.3的工程,res/layout 下的xml布局文件无法预览了, 一预览总是报这个错: ...

the rendering library is more recent than your version of android studio

最近更新了自己Android Studio中的SDK到最新版本,AS的一部分配置修改了。 然后 在打开布局文件的时候 会出现 渲染错误 Rendering problem the render...

Android studio提示“Plugin is too old”

这是一开始的配置信息, buildscript { repositories { jcenter() //声明使用maven仓库 } dependencies...

mac os 10.10 android studio 解决 svn “this client is too old ···”问题

原文地址:(解决的是 PHPstorm 上的问题,但是也适用我遇到的这个问题) http://andowebsit.es/blog/noteslog.com/post/how-to-upgrade-...

Android Studio:platform-tools is too old

今天用AS新建工程的时候,发现在包名的地方报错了,提示是 The SDK platform-tools version ((23.1)) is too old to check APIs compil...

Version of activiti database (5.15.1) is more recent than the engine (5.14)

org.activiti.engine.ActivitiException: Version of activiti database (5.15.1) is more recent than the...

"A more recent version of this document is supported by this" JPA persistence.xml问题

问题解决处:感谢stackoverflowhttp://stackoverflow.com/questions/3701901/eclipse-does-not-recognize-content-o...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Android studio 大BUG,Plugin is too old, please update to a more recent version
举报原因:
原因补充:

(最多只允许输入30个字)