【poj 1852】Ants

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output

4 8
38 207

一群蚂蚁在长度为l厘米的水平极上行走,每个长度为1厘米/秒的恒定速度。当一只蚂蚁到达极点的末端时,它立即脱落。当两只蚂蚁相遇时,他们转过身,开始走向相反的方向。我们知道蚂蚁在杆上的原始位置,不幸的是,我们不知道蚂蚁走路的方向。您的任务是计算所有蚂蚁脱落极点所需的最早和最新可能的时间。
输入

第一行输入包含一个整数,给出跟随的个案数。每个案例的数据从两个整数开始:极的长度(以厘米为单位),n为驻极点上的蚂蚁数。这两个数字后面是n个整数,给出了极点上每个蚂蚁的位置作为从杆的左端测量的距离,没有特定的顺序。所有输入的整数不大于1000000,它们由空格分隔。
产量

对于每种情况的输入,输出两个数字由单个空格分隔。第一个数字是尽可能早的时间,所有的蚂蚁都从杆上掉下来(如果他们的行走方向是适当的选择),而第二个数字是最近可能的时间。

日本白P18

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000000+1;
int a[maxn];
int q,l,n;
void solve()
{
    int maxx=0,minn=0;
    for(int i=1;i<=n;i++)
    {
        maxx=max(maxx,max(a[i],l-a[i]));
        minn=max(minn,min(a[i],l-a[i]));
    }
    cout<<minn<<" "<<maxx<<'\n';
}
int main()
{
    scanf("%d",&q);
    while(q--)
    {
        scanf("%d%d",&l,&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值