Sudoku 数独

Sudoku
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
 
    
submit
 
    
 
    
 
    
思想是一个一个数的开始进行搜索,判断该数是不是在这一列里没出现过,在这一行里没出现过,在对应的小正方形里没出现过,那么这个点就赋值该数
 
    
小技巧,知道数的个数(从第一行开始数,数到最后一行的最后一个数),改点的行坐标为n/9,列坐标为n%9,对应的小正方形的最左上角的点的行坐标为n/9/3*3,列坐标为n%9/3*3
 
    
AC代码:
#include<iostream>
#include<cmath>
#include<algorithm>
#include<stack>
#include<cstring>
#include<queue>
#include<cstdio>
#include<string>
using namespace std;

int maze[81][81];
int ans;

int check(int cnt, int num)
{
    int row = cnt / 9;
    int col = cnt % 9;
    int i, j;
    for(i=0; i<9; ++i) {
        if(maze[row][i] == num || maze[i][col] == num)
            return 0;
    }
    for(i=row/3*3; i<=row/3*3+2; ++i) {
        for(j=col/3*3; j<=col/3*3+2; ++j) {
            if((maze[i][j]) == num)
                return 0;
        }
    }
    return 1;
}

void dfs(int cnt)
{
    int row = cnt / 9;
    int col = cnt % 9;
    if(ans)
        return;
    if(cnt == 81) {
        ans = 1;
        return;
    }
    if(maze[row][col]) {
        dfs(cnt + 1);
        return;
    }
    int i;
    for(i=1; i<=9; ++i) {
        if(check(cnt, i)) {
            maze[row][col] = i;
            dfs(cnt + 1);
            if(ans)
                return;
            maze[row][col] = 0;
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--) {
        ans = 0;
        int i, j;
        for(i=0; i<9; ++i) {
            for(j=0; j<9; ++j)
                scanf("%1d", &maze[i][j]);
        }
        
        dfs(0);
        for(i=0; i<9; ++i) {
            for(j=0; j<9; ++j)
                printf("%d", maze[i][j]);
            printf("\n");
        }
    }
    return 0;
}


 
    
 
   
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值