Recursive sequence 矩阵快速幂 + 组合数 非线性变线性,利用到了组合数(杨辉三角求解快)

Recursive sequence
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 

Input

The first line of input contains an integer t, the number of test cases. t test cases follow. 
 Each case contains only one line with three numbers N, a and b where N,a,b <   as described above. 

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

Sample Input

2
3 1 2
4 1 10

Sample Output

85
369

        
  

Hint

     
     
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.
这个做了好久,真是醉了,就是查不出结果,自己动手算也没错,弄了大半天结果是因为自己的在求组和数的时候出错了,我。。。。
求组合数的时候可以用杨辉三角进行求解,代码如下:
void yanghui() {
	int i, j;
	C[0][0] = 1;
	for(i=1; i<=50; ++i) {
		C[i][0] = C[i][i] = 1;
		for(j=1; j<i; ++j) {
			C[i][j] = (C[i-1][j-1] + C[i-1][j]) % mod;
		}
	}
}
原理图:

AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define maxn 8
using namespace std;
typedef long long ll;
ll  k;
const ll mod = 2147493647;
int n = 7;
int rol, col;
struct Matrix {
	ll ma[maxn][maxn];
};

Matrix multi(Matrix a, Matrix b) {
	Matrix ans;
	memset(ans.ma, 0, sizeof(ans.ma));
	int i, j, k;
	for(i=1; i<=n; ++i)
		for(j=1; j<=n; ++j)
			for(k=1; k<=n; ++k)
				ans.ma[i][j] = (ans.ma[i][j] + a.ma[i][k]*b.ma[k][j]) % mod;
    return ans;
}

Matrix pow(Matrix a, ll x) {
	Matrix ans;
	memset(ans.ma, 0, sizeof(ans.ma));
	int i, j;
	for(i=1; i<=n; ++i)
		ans.ma[i][i] = 1;
	while(x) {
		if(x & 1)
			ans = multi(ans, a);
		a = multi(a, a);                         
		x >>= 1;
	}
	return ans;
}

int main()
{
	int t;
	ll f[3];
	scanf("%d",&t);
	while(t--) {
		Matrix ans, b;
		memset(b.ma, 0, sizeof(b.ma));
		scanf("%lld%lld%lld",&k, &f[1], &f[2]);
		if(k<=2) {
			printf("%lld\n",f[k]%mod);
			continue;
		}
		int i, j;
		ll num1[7] = {f[1], f[2], 16, 8, 4, 2, 1};
		ll num2[7][7] = {{0,2,0,0,0,0,0}, {1,1,0,0,0,0,0},{0,1,1,0,0,0,0},{0,4,4,1,0,0,0},{0,6,6,3,1,0,0},{0,4,4,3,2,1,0},{0,1,1,1,1,1,1}};
		for(i=1; i<=n; ++i)
			b.ma[1][i] = num1[i-1];
		for(i=1; i<=n; ++i)
			for(j=1; j<=n; ++j)
				ans.ma[i][j] = num2[i-1][j-1];
		ans = pow(ans, k-2);
		ans =multi(b, ans);
		printf("%lld\n",ans.ma[1][2]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值