九度 题目1461:Tempter of the bone

题目来源:http://ac.jobdu.com/problem.php?pid=1461

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:790

解决:302

题目描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed. 

输出:

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

样例输入:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
样例输出:
NO
YES
提示:

 用scanf读取输入。

一定要注意输入,不能边输入边判断,要不然会超时的,会以为其他还要优化,其实不然!只是输入的问题,害的我一直超时!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>

using namespace std;

const int MAXN = 10;

char Graph[MAXN][MAXN];
int iRow, iCol, T;
int iTarx, iTary;

bool IsCanGo(int x, int y)
{
    if(x < 0 || x >= iRow || y < 0 || y >= iCol)
        return false;
    return true;
}

int dir[4][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}};

int Fabs(int a)
{
    return a < 0 ? (-a) : a;
}

bool DFS(int x, int y, int cnt)
{
    if(x == iTarx && y == iTary && cnt == T)
        return true;
    int tmp = T - cnt - Fabs(x - iTarx) - Fabs(y - iTary);
    if(tmp < 0 || (tmp&1))
        return false;
    for(int i = 0; i < 4; ++i)
    {
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];
        if(IsCanGo(xx, yy) && Graph[xx][yy] != 'X')
        {
            Graph[xx][yy] = 'X';

            if(DFS(xx, yy, cnt+1))
                return true;
            Graph[xx][yy] = '.';
        }
    }
    return false;
}

int main()
{
    int i, j;
    int iStartx, iStarty, iWall;
    while(scanf("%d %d %d", &iRow, &iCol, &T) != EOF)
    {
        if(iRow == 0 && iCol == 0 && T == 0)
            break;
        for(i = 0; i < iRow; ++i)//一定要这么输入,如果遍读遍判断,一定会TLE到死的!
            scanf("%s", Graph[i]);
        iWall = 0;
        for(i = 0; i < iRow; ++i)
        {
            for(j = 0; j < iCol; ++j)
            {
                if(Graph[i][j] == 'S')
                    iStartx = i, iStarty = j;
                if(Graph[i][j] == 'D')
                    iTarx = i, iTary = j;
                if(Graph[i][j] == 'X')
                    iWall++;
            }
        }
        if(iRow * iCol - iWall <= T)
        {
            printf("NO\n");
            continue ;
        }
        Graph[iStartx][iStarty] = 'X';

        if(DFS(iStartx, iStarty, 0))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值