UVA - 10391 Compound Words(hash)

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn

题目大意:求出一个由两个单词组成的单词,并按照字典序输出。

解析:这题比较简单,直接暴力用set+string stl暴力求解,详见代码。

#include <string>
#include <set>
#include <iostream>
using namespace std;
int main() {
	string word;
	set<string> st;
	while(cin >> word) {
		st.insert(word);
	}
	set<string>::iterator it; 
	for(it = st.begin(); it != st.end(); it++) {
		for(int i = 1; i < (*it).size(); i++) {
			string front = (*it).substr(0,i);
			string rear = (*it).substr(i);
			if(st.count(front) && st.count(rear)) {
				cout << (*it) << endl;
				break;
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值