hdu 1010 Tempter of the Bone dfs+奇偶剪枝

H - Tempter of the Bone
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO

YES

题意:这道题目要求的是正好在T时刻走到出口!

思路:对剪枝完全没思路啊。。。

奇偶剪枝:

1、如果所给的时间小于最小步数step 那么一定走不到;

2、如果t>step,要正好在t时刻走到出口,那么一定要满足t-step为偶数;、

证明:

我们已知了最短的步数就是直角三角形的两条直角边,实际上的路径却不一定非要沿着这两条边走的。仔细看看只要是移动方向

一直是右、下,那么走到的时候总步数也一定是path的。然而由于墙的存在或许我们不可能一直右、下的走下去。为了避开墙,

我们可能会向左走,向上走等等。但为了到达目的地,你在最短步数的基础上,如果向右走了一步,那么某一时候也必须再向左

走一步来弥补。

即:绕过一个障碍要多走2步,那绕过n个障碍就要多走n*2步,所以剩余步数一定是偶数步才能绕到终点。

dfs中药用到的剪枝:

1、

如果墙的个数+步数大于方格数一定不行,因为题目中还有s和d;
2、
当前点(x,y)到终点(ex,ey)的最短距离abs ( (x - ex ) + abs (y - ey );如果t-step-s1-s2<0 那么一定不可以,剪枝
如果temp&1不为0 说明为奇数,剪枝


#include<stdio.h>
#include<string.h>
#include<math.h>
char a[10][10];
int book[10][10];
int go[4][2]={0,1,1,0,-1,0,0,-1};
int n,m,t;
int bx,by,ex,ey;
int flag;
void dfs(int x,int y,int step)
{      
       int i;
	   int s1=abs(x-ex);
       int s2=abs(y-ey);//到达终点的最小步数
       int temp=t-step-s1-s2;
       if(temp<0||temp&1)//判断是否为偶数
	     return ;
	    if(x==ex&&y==ey&&step==t)
		   {  flag=1;
		   }
		if(flag)
		  return ;
		for(i=0;i<4;i++)
		{    int tx=x+go[i][0];
		     int ty=y+go[i][1];
		     if(tx<0||tx>=n||ty<0||ty>=m)
			    continue;
		     if(book[tx][ty]==0&&a[tx][ty]!='X')
		           {   book[tx][ty]=1;
				       dfs(tx,ty,step+1);
				       book[tx][ty]=0;
					  }
		} 
	    return ;              
}
int main()
{   int i,j,ans;
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)
    {   if(n==0&&m==0&&t==0)
          break;
          memset(book,0,sizeof(book)); 
          ans=0;
          for(i=0;i<n;i++)
            scanf("%s",a[i]);
          for(i=0;i<n;i++)
           for(j=0;j<m;j++)
            {    if(a[i][j]=='S')
                  {   bx=i;
                      by=j;
				  }
				 else if(a[i][j]=='D')
				   {  ex=i;
				      ey=j;
				   }
				else if(a[i][j]=='X')
				ans++;
				
			}
			if(n*m<=ans+t)//小剪枝1,如果墙的个数+步数大于等于方格数一定不行,因为题目中还有s和d
			{   printf("NO\n");
			    continue;
			}
			flag=0;
			book[bx][by]=1;
			dfs(bx,by,0);
			if(flag)
			{  printf("YES\n");
			}
			else
			   printf("NO\n");
			
		    
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Marcus-Bao

万水千山总是情,只给五角行不行

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值