POJ 3268 - Silver Cow Party dijkstra+转置矩阵

31 篇文章 0 订阅

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:一群牛分别从1~n号农场赶往x号农场参加聚会,农场与农场之间的路是单向的,在n个农场之间有m条路,给出 a ,b , t表示从a号农场到b号农场需要t时间。 每头牛都会选择最短的路,问来回路上(i→x+x→i)花费时间最长的牛花费的时间是多少?


思路:题意其实很简单,一开始的想法也很简单,每头牛从x返回i的最短距离我们很好求,我们以x为源点求一个dijkstra就可以了,其实从i到x的最短距离也好求,我们只需要以i为源点求一个dijkstra找到对应的到x的最短距离,

但是我们枚举每个点的的话,时间复杂度为n^3 明显会超时;

处理方法:我们可以将原图的矩阵转置,也就是说原本从i到x的路径变成了从x到i的路径,从x到i的路径变成了从i到x的路径,那么我们在以x为源点求一遍dijkstra,此时所求的最短距离就为i到x的最短距离.

其实矩阵也不需要真的转置,我们只需要将 横纵坐标对调一下就好了。


#include<iostream>

#include<cstdio>

#include<cstring>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int map[1100][1100];
int book[1100],dg[1100],db[1100];
int n,m,x;
void dijkstra()
{   int i,j,min,v;
    for(i=1;i<=n;i++)
{   book[i]=0;
   db[i]=map[x][i];//回去的各个点的最短路径是以x为源点 
   dg[i]=map[i][x];//因为反向转置一下,以x为源点求去的时候的最短路径,正好是个反的 
}
for(i=1;i<=n;i++)
{    min=inf;
   for(j=1;j<=n;j++)
   {   if(!book[j]&&dg[j]<min)
    {   min=dg[j];
        v=j;
}
}
book[v]=1;
for(j=1;j<=n;j++)
{  if(dg[j]>dg[v]+map[j][v])//求回去的路径应该是相反的; 
  dg[j]=dg[v]+map[j][v];
}

memset(book,0,sizeof(book));
for(i=1;i<=n;i++)
{    min=inf;
   for(j=1;j<=n;j++)
   {   if(!book[j]&&db[j]<min)
    {   min=db[j];
        v=j;
}
}
book[v]=1;
for(j=1;j<=n;j++)
{  if(db[j]>db[v]+map[v][j])
  db[j]=db[v]+map[v][j];
}

return ;
}
int main()
{      int i,j,k;
       int a,b,c;
     while(cin>>n>>m>>x)
     {    
        for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
         {  if(i==j)
            map[i][j]=0;
            else
            map[i][j]=inf;
}
   for(i=1;i<=m;i++)
          {  scanf("%d %d %d",&a,&b,&c);
             map[a][b]=c;
 }
 dijkstra();
 int ans=-1;
 for(i=1;i<=n;i++)
 ans=max(ans,dg[i]+db[i]);
 printf("%d\n",ans);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Marcus-Bao

万水千山总是情,只给五角行不行

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值