HDU 1856 More is better (裸的并查集,记录下秩就可以了)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 12896    Accepted Submission(s): 4728


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题意:朋友圈问题,A和B是朋友,B和C是朋友则A和C也是朋友,依次类推,题目的意思就是求最大的朋友圈,即求最大集合中元素的个数。裸的并查集加个秩数组就行了。

注意当朋友对为0时要特判一下,这里wa了一次,有点不应该,因为题目中写的很清楚0<=n<=1000000。

#include <cstdio>
#include <cstdlib>
#include <climits>

const int MAX = 10000005;
int pre[MAX],rank[MAX],maxx;


void init(){
	int i;
	for(i=1;i<MAX;++i){
		pre[i] = i;
		rank[i] = 1;
	}
}

int root(int x){
	if(x!=pre[x]){
		pre[x] = root(pre[x]);
	}
	return pre[x];
}

void merge(int x,int y){
	int fx = root(x);
	int fy = root(y);
	if(fx!=fy){
		pre[fx] = fy;
		rank[fy] += rank[fx];
		if(rank[fy]>maxx)maxx = rank[fy];
	}
}


int main(){
	//freopen("in.txt","r",stdin);
	int i,n,x,y;
	while(scanf("%d",&n)!=EOF){
		if(n==0){
			printf("1\n");
			continue;
		}
		init();
		maxx = INT_MIN;
		for(i=0;i<n;++i){
			scanf("%d %d",&x,&y);
			merge(x,y);
		}
		printf("%d\n",maxx);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值