UVa 297 - Quadtrees

Quadtrees

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

A modern computer artist works with black-and-white images of  tex2html_wrap_inline34  units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter 'p' indicates a parent node, the letter 'f' (full) a black quadrant and the letter 'e' (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output Specification

For each test case, print on one line the text 'There are X black pixels.', where X is the number of black pixels in the resulting image.

Example Input

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Example Output

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.

 

 

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int k,pixels;
struct node
{
    int fe;
    struct node *t1;
    struct node *t2;
    struct node *t3;
    struct node *t4;
};
typedef struct node tree;
tree* count(char s[],int i)
{
    tree* newp;
    newp=(tree*)malloc(sizeof(tree));
        k++;
        if(s[k]=='f')
            {
                newp->fe=1;
                pixels+=i;
                newp->t1=NULL;
                newp->t2=NULL;
                newp->t3=NULL;
                newp->t4=NULL;
            }
        if(s[k]=='e')
            {
                newp->fe=0;
                newp->t1=NULL;
                newp->t2=NULL;
                newp->t3=NULL;
                newp->t4=NULL;
            }
        if(s[k]=='p')
        {
            newp->fe=0;
            newp->t1=count(s,i/4);
            newp->t2=count(s,i/4);
            newp->t3=count(s,i/4);
            newp->t4=count(s,i/4);
        }
    return newp;
}
void m(tree*h,int i)
{
    if(h->fe==1)
    pixels-=i;
    else
        if(h->t1!=NULL)
    {
        m(h->t1,i/4);
        m(h->t2,i/4);
        m(h->t3,i/4);
        m(h->t4,i/4);
    }
}
void minus(tree*h1,tree*h2,int i)
{
    if(h1->t1==NULL&&h2->t1==NULL)
        {
            if((h1->fe==1)&&(h2->fe==1))
            pixels-=i;
        }
    else
    if(h1->t1==NULL)
    {
        if(h1->fe==0)return;
        else
            m(h2,i);
    }
    else if(h2->t1==NULL)
    {
         if(h2->fe==0)return;
        else
            m(h1,i);
    }
    else
    {
        minus(h1->t1,h2->t1,i/4);
        minus(h1->t2,h2->t2,i/4);
        minus(h1->t3,h2->t3,i/4);
        minus(h1->t4,h2->t4,i/4);
    }
}

int main()
{
    int n;
    char a[10000],b[10000];
    tree*h1,*h2;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        pixels=0;k=-1;
        gets(a);
        gets(b);
        h1=count(a,1024);
        k=-1;
        h2=count(b,1024);
        minus(h1,h2,1024);
        printf("There are %d black pixels.\n",pixels);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值