关闭

Linux下如何安装最新版本工具

标签: linuxlinux工具安装离线安装最新工具
386人阅读 评论(0) 收藏 举报
分类:

此博文主要考虑到两个方面的需求:
1.主机处于离线状态,需要离线安装相关工具包;
2.主机的软件源不是最新的,通过在线更新无法达到需求的版本;

此文以获取openssh相关工具包,其他工具包原理类似:
1.首先找到工具包的官网地址,这里是:www.openssh.com;

2.根据导航找到需要的离线资源包,这个因网站而异,有的在网址首页,有的在Download/Source等目录下,这里的链接为:OpenSSH: Portable Release
http://www.openssh.com/portable.html#http

3.找到资源包之后,下载并拷贝至目标Linux主机目录下,这里为:openssh-7.3p1.tar.gz

4.解压该压缩包,进入解压后目录,这个时候步骤就很统一了。一般情况下,目录里面会存在 README,INSTALL,configure等文件,我们只需要打开INSTALL文件按照上面的步骤顺序一步步安装就可以啦。若出现问题,要参考说明文件解决相关依赖和设置问题~~

1
0
查看评论

Linux下源码安装nginx-1.9.11

Linux下安装nginx图解 环境linux版本:centos6.5 nginix版本:nginx-1.9.11.tar.gz
  • hsd2012
  • hsd2012
  • 2016-05-11 17:46
  • 3705

安装最新版本的nodejs

sudo apt-get install npm sudo npm cache clean -f sudo npm install -g n sudo n latestsudo ln -sf /usr/local/n/versions/node/<VERSION>/bin/node /u...
  • wlmnzf
  • wlmnzf
  • 2017-08-02 09:11
  • 713

【Docker安装】- Ubuntu14.04中安装最新版的Docker

docker在ubuntu14.04下的安装 安装docker root@ubuntu:~# docker version 获取最新的Docker包 root@ubuntu:~# wget -qO- https://get.docker.com/ | sh 启动docker服务 ro...
  • shenzhen_zsw
  • shenzhen_zsw
  • 2017-07-03 22:34
  • 1105

linux下如何安装最新版本的nodejs

分以下三步,亲测有效。 1. sudo apt-get update 2. sudo apt-get install n 3. sudo n stable
  • DlMmU
  • DlMmU
  • 2017-10-12 22:30
  • 58

在Centos6.5版本分布式安装Glusterfs3.8版本

1. 登入root用户 sudo su root   2. 设置主机名 修改hostname文件,以及hosts文件添加如下设置,使集群中的主机可以通过主机名进行访问: 10.0.101.2 gfs1 10.0.101.191 gfs2 10.0.101....
  • zhou_shaowei
  • zhou_shaowei
  • 2017-07-26 11:49
  • 635

CentOS 安装高版本git

来源自我的博客 http://www.yingzinanfei.com/2016/09/22/centos-anzhuanggaobanbengit/CentOS6.5自带的git版本是1.7.1 卸载自带的git # yum remove git 下载最新版git # wget https:/...
  • yingzinanfei
  • yingzinanfei
  • 2016-11-14 22:19
  • 1296

安装新版本Cmake

转载地址:https://askubuntu.com/questions/610291/how-to-install-cmake-3-2-on-ubuntu-14-04 Ubuntu14.04 自带的Cmake2.8.7 没有卸载,直接下载的源码包,编译,安装的,默认安装的位置是: /us...
  • u011722133
  • u011722133
  • 2017-11-24 10:57
  • 380

linux安装最新版jdk步骤

linux安装jdk
  • u013257425
  • u013257425
  • 2016-11-05 16:08
  • 444

安装最新版本git

安装最新版本git系统 CentOS6.51:更新系统sudo yum update 2:安装依赖包 sudo yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel gcc perl-ExtUtils-...
  • zhangruizhou001
  • zhangruizhou001
  • 2016-12-09 16:38
  • 833

错误记录--正尝试安装的Adobe(R) Flash(R) Player版本不是最新的版本

flash player安装失败。 卸载程序uninstall_flash_player。 正尝试安装的Adobe(R) Flash(R) Player版本不是最新的版本。 安装每次到100%的时候就会显示无法注册Flash Player的ActiveX的控件。
  • xinxin19881112
  • xinxin19881112
  • 2011-01-18 01:37
  • 4484
    个人资料
    • 访问:200437次
    • 积分:3432
    • 等级:
    • 排名:第11578名
    • 原创:118篇
    • 转载:23篇
    • 译文:6篇
    • 评论:114条
    最新评论