UVA315 Network(tarjan求割点)

4 篇文章 0 订阅
1 篇文章 0 订阅


Network

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

 

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at mostN lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

 

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

 

Sample Input

 

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

 

Sample Output

 

1
2

————————————————————————————————————————————————

题目的意思是给出一张有向图,求割点,输入方式比较复杂

思路:模板裸题

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
#define mem(a,b) memset(a,b,sizeof a)
const int INF = 0x3f3f3f3f;
#define MAXN 100100
#define MAXM 1000100

struct node
{
    int u,v,next;
} edge[MAXM];

int dfn[MAXN],low[MAXN],s[MAXN],fl[MAXN],in[MAXN];
int cnt,ans,tot;

void init()
{
    mem(in,0);
    mem(s,-1);
    mem(fl,0);
    mem(dfn,0);
    mem(low,0);
    cnt=tot=0;
}

int add(int u,int v)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].next=s[u];
    s[u]=cnt++;
}

void tarjan(int x,int root)
{
    dfn[x]=low[x]=++tot;
    in[x]=1;
    int cnt=0;
    for(int i=s[x]; ~i; i=edge[i].next)
    {
        int v=edge[i].v;

        if(!dfn[v])
        {
            tarjan(v,root);
            low[x]=min(low[x],low[v]);
            cnt++;
            if(x==root&&cnt>1)
                fl[x]=1;
            if(x!=root&&dfn[x]<=low[v])
            fl[x]=1;
                  }
        else
        {
            low[x]=min(low[x],dfn[v]);
        }
    }

}

int main()
{
    int n,u,v;
    char c;
    while(~scanf("%d",&n)&&n)
    {
            init();
        while(scanf("%d",&u)&&u)
        {
            while(scanf("%d%c",&v,&c))
            {
                add(u,v);
                add(v,u);
                if(c=='\n') break;
            }
        }
        for(int i=1;i<=n;i++)
        if(!dfn[i]) tarjan(i,i);
        ans=0;
        for(int i=1;i<=n;i++)
            if(fl[i]) ans++;
        printf("%d\n",ans);
    }


    return 0;
}


Tarjan算法是一种用于解决最近公共祖先(LCA)问题的离线算法。离线算法指的是在读取所有查询之后一次性计算所有查询的答案,而不是每读取一个查询就计算一次。\[1\] 在Tarjan算法中,需要使用并查集来实现。并查集是一种数据结构,用于维护元素之间的集合关系。下面是一个并查集的模板代码: ```cpp int fa\[100000\]; void reset(){ for (int i=1;i<=100000;i++){ fa\[i\]=i; } } int getfa(int x){ return fa\[x\]==x?x:getfa(fa\[x\]); } void merge(int x,int y){ fa\[getfa(y)\]=getfa(x); } ``` 在Tarjan算法的伪代码中,首先标记当前节点为已访问状态。然后遍历当前节点的子节点,递归调用Tarjan函数并合并子节点。接下来,遍历与当前节点有查询关系的节点,如果该节点已经访问过,则输出当前节点和该节点的LCA(通过并查集的查找函数getfa获取)。\[3\] 以上是关于Tarjan算法解LCA的相关内容。 #### 引用[.reference_title] - *1* [Tarjan 算法解决 LCA 问题](https://blog.csdn.net/chengqiuming/article/details/126878817)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [详解使用 Tarjan LCA 问题(图解)](https://blog.csdn.net/weixin_34315485/article/details/93801193)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值