【动态规划】【数位DP】[2015 Multi-University Training Contest 7]Gray Code

题目描述

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.
这里写图片描述
Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.

The first line of the input contains the number of test cases T.
Each test case begins with string with ‘0’,’1’ and ‘?’.
The next line contains n (1<=n<=200000) integers (n is the length of the string).
a1 a2 a3 … an (1<=ai<=1000)

样例输入

2
00?0
1 2 4 8
????
1 2 4 8

样例输出

Case #1: 12
Case #2: 15

题目分析

就是个裸的DP如果当前为?就看前面是否为?然后我们对于相邻的两位有9种状况分别为??、?1、?0、1?、11、10、2?、21、20然后分别进行DP

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 200000;
int v[MAXN+10], f[MAXN+10][2];
char str[MAXN+10];
int main(){
    int T;
    scanf("%d", &T);
    for(int t=1;t<=T;t++){
        scanf("%s", str+1);
        int len = strlen(str+1);
        for(int i=1;i<=len;i++)
            scanf("%d", &v[i]);
        str[0] = '0';
        f[0][0] = 0;
        f[0][1] = 0;
        for(int i=1;i<=len;i++){
            if(str[i] == '?'){
                if(str[i-1] == '?'){
                    f[i][0] = max(f[i-1][1]+v[i], f[i-1][0]);
                    f[i][1] = max(f[i-1][0]+v[i], f[i-1][1]);
                }else if(str[i-1] == '0'){
                    f[i][0] = f[i-1][0];
                    f[i][1] = f[i-1][0]+v[i];
                }else{
                    f[i][0] = f[i-1][1]+v[i];
                    f[i][1] = f[i-1][1];
                }
            }else if(str[i] == '0'){
                if(str[i-1] == '?')
                    f[i][0] = max(f[i-1][0], f[i-1][1]+v[i]);
                else if(str[i-1] == '1')
                    f[i][0] = f[i-1][1] + v[i];
                else f[i][0] = f[i-1][0];
            }
            else{
                if(str[i-1] == '?')
                    f[i][1] = max(f[i-1][1], f[i-1][0]+v[i]);
                else if(str[i-1] == '1')
                    f[i][1] = f[i-1][1];
                else f[i][1] = f[i-1][0] + v[i];
            }
        }
        printf("Case #%d: ", t);
        if(str[len] == '?') printf("%d\n", max(f[len][0], f[len][1]));
        else printf("%d\n", f[len][str[len]-'0']);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值