HDU 1034 Candy Sharing Game

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6052    Accepted Submission(s): 3674


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

Source


一群学生围着老师坐,每个学生手里有一定数量的糖,老师吹口哨开始每个学生将自己糖数的一半分给自己右边的同学,同时如果同学手中的糖数为奇数,老师将会再分给他一颗糖,问经过多少次循环之后每个同学手中的糖数会是相等的。输出最后相等时候的糖数以及老师吹口哨的次数,也就是循环的次数。

#include<iostream>
using namespace std;

bool judge(int a[],int N){
	int b=a[1];
	for(int i=2;i<=N;i++)
	{
		if(b!=a[i])return false;
	}
	return true;
}

int main(){
	int N;
	while(cin>>N&&N){
		int *a = new int[N+2];
		int step=0;
		for(int i=1;i<=N;i++)cin>>a[i];
		while(!judge(a,N))
		{
			a[0]=a[N];
			for(int i=N;i>0;i--)     //从右端开始
			{
				a[i]=a[i-1]/2+a[i]/2;
				if(a[i]&1)++a[i];   //按位与,判断是否为奇数
			}
			step++;
		}
		cout<<step<<" "<<a[1]<<endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值