[POJ - 2485 ] Highways(最小生成树&&并查集)

Link:http://poj.org/problem?id=2485

题目:

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

题意:

求最小生成树中的最长路径 

*注:此题输入为矩阵

Code:

*Kruskal

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;
const int maxn=1e6+10;
int par[maxn];
struct node
{
    int a,b,l;
}r[maxn];
bool cmp(node a,node b)
{
    return a.l<b.l;
}
int find(int x)
{
    return x==par[x]? x:par[x]=find(par[x]);
}
bool unite(int a,int b)
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
    {
        par[fa]=fb;
        return true;
    }
    return false;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,i,j,k=0;
        scanf("%d",&n);
        for(i=0;i<=500;i++)
            par[i]=i;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                scanf("%d",&r[k].l);
                r[k].a=i;
                r[k].b=j;
                k++;
            }
        sort(r,r+k,cmp);
        int c=0,ans=0,max=-1;
        for(i=0;i<k;i++)
        {
            if(unite(r[i].a,r[i].b))
            {
                c++;
                ans+=r[i].l;
                if(r[i].l>max)
                    max=r[i].l;
            }
            if(c==k-1) break;
        }
        printf("%d\n",max);
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值