《ACM程序设计》书中题目P(会贿赂猫的胖老鼠)

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input


5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output

13.333
31.500



题目大意就是一只胖老鼠会用猫粮和猫换食物,每间房的猫“汇率”都不一样,问如何换才能得到最多的食物;


思路如下:


1.根据每间房需要的猫粮和能换的食物来进行计算,算出“汇率”;

2.对汇率进行排序,选出交换的优先级;

3.一个一个计算直到猫粮耗尽为止。



程序如下:

#include<bits/stdc++.h>
using namespace std;
struct Food
        {
                double j;
                double f;
                double a;
        };
bool cmp(const Food &a, const Food &b)
{
     return a.a>b.a;
}
int main()
{
        Food x[1000];
        int m,n,i;
        double s;
        while(cin>>m>>n)
        {
                if(m==-1)
                        break;
                s=0;
                for(i=0;i<n;i++)
                {
                        cin>>x[i].j>>x[i].f;
                        x[i].a=x[i].j/x[i].f;  //计算每间房的汇率
                }
                sort(x,x+i,cmp);   //对汇率进行排序
                for(i=0;i<n;i++)   //计算结果
                {
                        if(m>=x[i].f)
                        {
                                m-=x[i].f;
                                s+=x[i].j;
                        }
                        else
                        {
                                s+=(x[i].a*m);
                                break;
                        }
                }
                cout<<setiosflags(ios::fixed)<<setprecision(3)<<s<<endl;
        }
}


要注意保留3位小数。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值